Roon CPU spikes

Roon Core Machine

Desktop computer, Windows 10, Ryzen 9 5950x CPU, 32G memory

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Unknown, but not that much maybe a few hundred CDs (a few thousand tunes).

Description of Issue

Roon spikes one core every now and then, especially after started or after it has been idle for a while. In itself this might not be that bad (but then again maybe it is, haven’t tested), but I also use HQPlayer and the result during these spikes is that the music gets interrupted several times (like a 1 second pause) during the CPU spike. The CPU spikes lasts about 10-20 seconds.

I have set “Background analysis speed” and “On-demand analysis speed” to throttled but that didn’t help. I also did a clean up of the library.

What happens, if you set them to “off” as a test?
Maybe your solution is to run HQP on a separate machine…

1 Like

Please give us a performance view of your machine?
My freshly built Core is playing music at this time, running for about 20hours or so.

(I restored a backup from another Win Core yesterday so it didn’t have to analyze 150K files)

This when playing music and nothing else, Roon is behaving at this time so takes around 0.3% CPU, the rest is HQPlayer

But it seems like setting both library-analysis to “Off” made a difference, no problem since I did that. But I don’t want them off for other reasons.

FYI: no DSP, volume levelling or anything else in Roon.

Well, just switch it off for trouble-free listening sessions and then back on for letting house keeping take over while not listening?!

Roon just can’t make it a set-it and-forget-it smooth ride for all use cases and all set-up combinations - bunch of losers :wink:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.