Roon crash when clicking on certain artist (King Pelican)

I just had the same problem on the group King Pelican. I had the album “Matador Surfer” on my local drive. Clicking in the artist name on any page caused Roon to freeze. I moved the group to an unwatched folder, restarted Roon, and the problem disappeared. I added the files one by one back into Roon, and only tracks 1-3 did not cause Roon to freeze when clicking on either the artist, or the album name. I again took the album out of Roon, and replaced it with an alternate copy of the album, with the same result. After again removing the local copy from Roon, I found it in Qobuz and added it as a Qobuz album. Roon froze again. The same freezing occurred when I added the Qobuz version of “The Good, The Bad and the Reverb”, also by King Pelican. So, except for three tracks, this artist causes Roon to freeze from either local or Qobuz albums. My core is a Dell XPS8930 with 16GB of memory, running the latest build of Windows 10 Pro, 64 bit. I run an AQ Ethernet cable to a 16 port Netgear router, with is connected to my Xfinity modem. My WD PR4100s are also connected to the Netgear router via AQ cabling. Roon is v1.8.795. After finally removing everything King Pelican related from Roon, and verified everything was properly working, I did a backup, uninstalled Roon, and everything Roon related from my computer (except backups which are on a dedicated SSD backup drive), downloaded a fresh 1,8 copy from Roon and installed it, then restored from that backup I just did. The same problem still persists. HELP, @support, please!

Hello @Neil_Russell,

Thank you for sharing in detail the way you are experiencing this crash - I am sorry and all the more because you have tried so many steps to find a solution. Thank you for your effort! :pray:

We’d love to help and to that end I’m looping in @noris, so he can ask for any more details and share any insights he might have :nerd_face:

Hello @Neil_Russell ,

I have split your post into it’s own thread so that we can assist you better.

Can you please confirm if a fresh database also has this behavior, or does it only occur when using the restored Roon database? You can use these instructions to set up a fresh Roon database:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if issue persists on fresh database before restoring the backup

After checking for the fresh database aspect, can we please request that you reproduce the issue, note the exact local time + date of the crash and use these instructions to send us a manual log set for review?


This topic was automatically closed after 21 hours. New replies are no longer allowed.