Roon crashes after click on disable multi-part compositions when using MacOS client [Ticket In]

It is not often I have the luxury of communicating with someone so High up in the Roon organization. Thank you for that.

RE: future software updates.

There also seems to be a bug where if a track is edited while it’s playing it causes Roon to crash. Then the controller for my IMAC does not open.

I was unable to select the zone that was being used while the edited track was playing. Lost ability to use ROON for 3 or 4 days. Then a user called my attention to the “editing a track while it’s playing”.

the fix was I went and undid the edits I had saved while track was playing and it was fixed…I could again select and use the affected zone.

I have no idea what it would take to resolve this bug but am hoping to help someone who does this down the road by calling your attention to it. I hope this is not an inappropriate place in the forum to bring this up. Apologies if it is.

Thanks for Roon and Happy New Year


1 Like

Hi @thomas_clark1 , regarding the editing – can you tell me more about the track, and exactly how you edited it?

We are not able to reproduce the issue by simply editing a track during playback, but maybe we could with more information about the edit you were performing.

Let me try and remember
Track was playing.
I chose "disable multi composition " as soon as I hit save the desktop app crashed
When I tried to reopen it it would briefly appear and then crash.
Pretty sure music continued to play.
As part of trying to get the desktop to work I rebooted the nucleus.
When it restarted the desktop still crashed
When I tried to use my phone the app opened but I could not select the zone I use for music.

After 4 days with Roon support a user called my attention to a thread describing a similar issue.
That was solved by going back to the track in question and checking the “multi comp” thing and once I saved it the zone could once again be selected.
Now that things were back I then disabled the multi track and saved. Things went fine as the track was not playing

I really appreciate you asking and checking it out

Thanks @thomas_clark1, I was able to reproduce the issue.

1 Like

That’s great glad I could help

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.