Roon Crashes on start

Roon Core Machine

W11, ASUS PRIME Z390-A, i9-9900k@3.6GHz, 16GB

Networking Gear & Setup Details

netgear switches, wired connections

Connected Audio Devices

  1. Euphony Stylus EP/roon EP via USB to dCS Debussy
  2. Allo Boss streamer DAC, Volumio
  3. Local Desktop

Number of Tracks in Library

~7.500 albums
~130.000 tracks
Synology DS218j

Description of Issue

Normally I run ROON on a W10/NUC 7i7-BNH.
Roon did not start. Crashed on start-up.
Tried a clean installation on my main system (Asus Prime z390).
Roon started an then after adding almost 2.500 albums, crashed.
ROON 2 ROON_OLD, fresh installation, firewall permits roon & raat, adding 2.414 albums started crashing again.
I have my log files in

Please be so kind to check and advise!

Best regards
Christos Patelis

Can I Have an answer to my problem?
I Have tried to start over importing my library to ROON from my main Synology 1817+ NAS.
Roon Crashes after almost 4.600 albums and never starts again.
If I start it without access to the library (NAS) I can stream form TIDAL and I see only TIDAL albums in my “library”.
I provide a recent set of LOG files.

Best Regards,
Christos Patelis