Roon crashes when a firewall is blocking ntp request or traffic

latest Mojave 10.14.6, MacBookPro 15" mid 2015, latest Roon, LuLu 1.2.0 blocking Roon process

fresh install, OS, Roon and firewall app.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Starting Roon LuLu opens a first-time pop-up and I allowed Raats and temporarily blocked Roon. The FW message reads: Roon is trying to connect to A little while later Roon crashes. Starting Roon again and allowing requests it starts without issues. Hope this be can be easily reproduced. Can provide logs per request.

Even though blocking Roon’s network traffic may be uncommon, I’m wondering if there might be a more sophisticated approach to handle this rather than crashing :wink:


While I would wish that it would be possible to set the Roon Core to sync with a locally provided ntp service it may not be too harmful to let the Roon Core sync its time.

On the other hand there were reports that Roon installations worked without internet connection as long as the authorization token was valid (maximum of 30 days). So the root cause of the crash could be unrelated to the ntp request blocking.

Hi @Ulli_Bick,

I’ve passed this information along to the team for investigation.

I do want to point out, though, that Roon makes use of NTP in various ways as noted here, so it’s best to leave it unblocked if possible.

I couldn’t repeat this on my MacBook with LuLu installed or Ubuntu Server (blocking UDP 123.)

Hi there,

the ntp related pop-up is the only one I receive from the firewall. Subsequent connection requests to different ports/protocols may get blocked as well. I did not raise the issue because I want to block time sync but to suggest to handle this condition via an exception and generate an error message rather than a crash.

I got curious and installed LuLu on my Roon server (iMac) and Roon also crashes when LuLu blocks it. And again, when I allow traffic Roon starts normally and vice versa … . HTH to clarify.
It’s a fresh install and with the firewall in place the crashes happen while Roon is displaying the ‘Choose your Roon Core’ dialog.

Hi @Ulli_Bick,

The team is looking into this and trying to reproduce what you’re seeing. Can you confirm what version of LuLu you’re using, along with some details on the settings that you’re using so we can reproduce this issue?


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.