Roon crashes when indexing NAS

1. Core Machine (Operating system/System info/Roon build number)

OS Name Microsoft Windows 10 Pro
Version 10.0.18362 Build 18362
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer Microsoft Corporation
System Model Surface Pro 4
System Type x64-based PC
System SKU Surface_Pro_4
Processor Intel® Core™ i5-6300U CPU @ 2.40GHz, 2496 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date Microsoft Corporation 108.2706.768, 18-Apr-19
SMBIOS Version 3.1
Embedded Controller Version 255.255
BaseBoard Manufacturer Microsoft Corporation
BaseBoard Product Surface Pro 4
BaseBoard Version Not Available
Platform Role Slate
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = “10.0.18362.387”
Time Zone FLE Standard Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.93 GB
Available Physical Memory 3.79 GB
Total Virtual Memory 14.7 GB
Available Virtual Memory 8.75 GB
Page File Space 6.75 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

… running Roon 1.6 (Build 416)

>>NAS details
Model: Synology DS212j
CPU: MARVELL Kirkwood 88F6281
CPU Clock rate: 1.2Ghz
CPU Cores: 1
RAM: 256MB
DSM version: 6.2.2-24922

The NAS Connected to a HP ethernet switch, which in turn is connected to the ARRIS Gateway (see below).

2. Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

The Core machine and audio devices are connected to the Arris gateway:
>>> ARRIS Hardware Information

System: ARRIS EuroDOCSIS 3.0 / EuroPacketCable 1.5 Touchstone Residential Gateway
SW_REV: 9.1.103DE2.EURO
MODEL: TG2492S-85
Serial Number: 7792SZ568402630

>>> ARRIS Firmware Build and Revisions

Firmware Name: TS0901103DE2_031219_24XX.GW
Firmware Build Time: Tue Mar 12 13:33:29 EDT 2019
eSAFE 0 FW Revision: TS0901103DE2_031219_ARRIS_GW

3. Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Model Name: Klimax Renew DS/1
Product Id1383202
Software Version4.70.300
Software VariantFw822

Description Of Issue

Roon crashes on launch (UI just never finishes loading and the window vanishes without any error message) if NAS is connected to the network. It has indexed the music collection in the past but now when it re-scans the NAS content it either crashes right away (before the UI has even loaded) or after 1-2 minutes, if the NAS is busy (typically backup is running at the same time).

In the latter case, I’ve been able to follow the scanning via menu->settings->storage. I can see that Roon has indexed about 12k songs of 16k files. After this, when back in the overview-section, clicking the circle on the top right shows that Roon keeps discovering some dozens of files every few seconds. Right about this time Roon will vanish without any error message

Hi @igufi,

Was this a new Roon install / import of media from the NAS or was this working previously?

If this was working previously, was there any change to your setup? Did you recently add new media that seemed to have corresponded with this?

Sorry, my message got posted before I had finished writing the details. Please see my original message with the edits.

As for the question, there were no changes to the setup, beyond the monthly Windows 10 updates to the Core Machine, all which have installed themselves without any noticeable issues.

Hi @igufi,

Moving forward, I’m hoping you can do the following:

  • Reproduce the crash 3 more times, make a note of the times the crashes occur
  • After the 3rd time this happens, use the instructions found here and send us over a set of logs using a shared Dropbox link
  • Respond here with the link to the logs and the timestamps from when the crashes occurred

After this our team will take a look at the logs you’ve sent over.


Thanks, @igufi — I’ve passed the logs along to the technical team and I’ll follow up as soon as I’ve received their feedback.

Hi @igufi,

The team took a look at the logs and it looks like the following media is causing an issue:

\DISKSTATION\Music\Adam Sandler collection

Can you try moving the entire Adam Sandler Collection folder our of the Roon watched folder and let us know if this crash is still occurring?

I moved the folder away and tried running Roon again with the same result. I noticed another mp3 album listed as corrupted in the logs and moved that folder away, too. Roon will still crash on startup but no particular albums/files are highlighted in the logs anymore.

I ran Roon three more times and here are the new log files (created today):

Thanks, @igufi — There may be some other media that’s causing an issue here too. I’ll get this over to the team and have them take another look.

Dear Dylan, it’s been almost a month - any updates on this issue?

Hi @igufi,

Apologies or the delay here. I spoke with the team about this, and we are hoping we can try to start with a fresh database and see if the same behavior occurs in this configuration. Please see the steps outlined below:

  • Close Roon on the Core machine
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.