Roon crashes with MacOS Mojave

Hi Guys

I know that there has been considerable discussion regarding Roons compatibility with Mojave betas and the workaround that went with that. When I followed this advice all worked as expected and everything was great. However, I am now running the released version of Mojave (10.14.1) and again all was working as expected but for about a week now, maybe a bit longer, Roon has been crashing for no apparent reason. I have even re-installed Roon but to no avail. I also did the workaround again just in case but no change. Please help!

Best Regards

Harry M

@Harry_Mulligan I think it would be useful to share details of your setup as defined in the following post and specifically what versions of Roon you’ve been running (including the betas) and what workarounds you have applied. Then copy in @support.

Hi @Harry_Mulligan,

Just to verify, Roon is crashing immediately when you’re trying to open it?

Do you have any active antivirus or firewall software on the Core machine? If so, can you try temporarily disabling and let me know if there is any change?

Hi Martin and Dylan

Thank you for your replies to this. I have just spent a while trying to get this working myself and I wanted to be sure I had the latest Roon Build (1.5 build 360) so I re-downloaded Roon and installed that version, did a restart and now it’s working again!!! I’ve been testing it as much as I can and each time it has remained stable whereas before it was crashing out completely when it attempted to load up or, on the few occasions where it would actually load, it would then crash when I tried to do anything in the app. So all seems good for now. I’m sorry I sort of jumped the gun on this but I’m relieved that the app is now working again as expected.

Thanks again for your prompt replies.

Best regards

Harry M


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.