Roon crashing on Android 10 (Fixed in Build 433)

I updated my Pixel2 to Android Q as they are typically pretty stable once they hit the public beta periods. The only issue I’m running into is that Roon no longer works with Android Q. It starts up, but I can’t get past the black screen with the ROON logo.

Remove and reload Roon from the device and see what happens.

Same thing unfortunately.

Yup, same thing here. Also broke the app for my networked AVR. 1st Gen Pixel…

@support, I think this might be something the dev team need to look at?

Fortunately Q is still in beta with plenty of time for the Roon dev team to get things working in anticipation of GA this fall.


Same problem here after updating my Pixel 3 to Q. Almost all of my other apps work without any real issues. Only Roon won’t start and that is one of the apps i use a lot. Thankfully the Lumin app works so i can play my music but that is no Roon.

Hopefully there will be an update soon that fixes this issues even though it is just a beta (that has been released only a few days ago).

@support Is there any news about this? Can we expect an update any time soon or is it tough luck and we have to wait when the final Android Q will be released? Just curious.

We’re tracking this report and keeping an eye on Android Q.

We don’t do a lot of testing on pre-release operating systems, since many issues end up fixed by the official release. Generally speaking, chasing bugs in “preview” OS versions is a bad use of dev resources, but we’re actually doing some work on Android right now so we’ve been discussing this a bit.

I don’t think anyone in the company is running Android Q yet, but as it gets closer to an official release we’ll make sure this gets resolved, of course.

For the moment, there’s no real timeline for us to share, and I’d generally recommend against OS previews if using Roon on a given device is critical for you.


No problem. Roon runs fine on my chromebook and i can also use the Lumin app on my phone in the meantime. I was just wondering since Roon is the only app on my phone that doesn’t work on the Android Q beta. Every other app works just fine.

Maybe it will work on the next beta and otherwise i’ll eagerly await the next update of the Roon app.

There’s a new beta 2 patch that was released today if someone has a chance to test. I had to revert to the public stable release for other reasons, so I’m unable to see if the latest patch resolves anything.

I installed the patch when it was released but there is no change. The Roon app stil doesn’t work.

Personally i think we have to wait till the final release of Q and an update of the Roon app before it will work again. It is too bad but that is a risk when installing beta software.

Same problem here. Roon Remote app does not work on Android Q.

Hi @Christopher_Ose/@Rdg/@Alex_Reusch,

I just wanted to check in with you here to see if there was any change to this issue with our latest Roon release (build 416). Are things still not working as expected or are you remotes now able to connect?

– Noris

When I run the April 24th build (latest?) of Roon on my Pixel 2 XL with Android Q beta, I get the black screen with Roon across it (like splash screen), but it goes no further.

The same behavior as before (unfortunately). The splash screen with the Roon logo appears and the app hangs from there.

On the bright side: the latest app does work a lot faster on my Chromebook.

Thanks for the feedback here @Rdg & @pstrisik. We were hoping something might have changed with the new Android updates we pushed out but this seems not to be the case for Android Q, thanks for confirming. As we get closer to the release we will be internally discussing this behavior further.

– Noris

I think it is very early in the Q beta. Crashing for me are Kaspersky and Firefox. There should be a new Q beta release before long. It has been about a month.

Besides Roon the only other app that is not working for me is the Yamaha MusicCast app. Other apps work just fine.

@noris : Just like pstrisik mentions there should be a new release any day now. Perhaps it fixes it and otherwise we just need to be patient.

If you need people to test beta apps of Roon to tackle this issue, then i would love to help out.


Slightly off topic (mods feel free to move or create new post) but how are you running Roon (control) on a Chromebook? I assumed it was a no no, but it would be perfect for my situation (says he typing this on a Chromebook!)