Roon crashing on M1 Macs using Monterey 12.3+ with EXC_BAD_ACCESS (SIGABRT)

Hi All,

Can you please confirm if you are still seeing this issue on the latest Roon release? If you are, can you please reproduce the issue and then upload a set of logs by using these instructions to access them?

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

Hi Noris,

I’m experiencing crashes at launch even with 936. It happens 3 out of 10 times. After Roon Remote app opens, it works fine. Can’t find what is triggering these crashes.

Here is my info:

Roon Core Machine

Intel NUC 10i7FNHN Roon ROCK

Networking Gear & Setup Details

Hard wired Ethernet on an NetGear Switcher to ASUS RT-AX86U

Connected Audio Devices

Matrix Audio X-SABRE 3, ARCAM ST60 and BlueSound NODE.

Number of Tracks in Library

8000 Tracks

Description of Issue

Roon Remote app crashes at start 3 out of 10 times in my Mac Studio M1 Max 32GB RAM. This is happening since I got my Mac Studio 3 weeks ago. It happened with 918, 933, 935 and now with 936. Most of the time I get the “Looking for Roon Core” message for about 3 secs then Roon starts or it crashes. Then I get a report with the option to Cancel or Reopen Roon app. If I press Reopen, Roon starts successfully. BTW, Roon is the only app that crashes on my Mac Studio. Private Relay is disable in my Mac Studio as well.

PS: Just uploaded my LOGS after a recent crash.

I’m also seeing frequent crashes on startup of Roon Client. Running client on macOs 12.3.1 on Apple M1 Pro MacBook Pro. Roon Core is on an Intel Nuc. Other Roon clients (iOS) are working fine.

Hi All,

Thanks for the reports, it sounds like the common pattern here is that the behavior happened after updating to Monterey 12.3 and that the system-level logs are showing a EXC_BAD_ACCESS (SIGABRT). For those still impacted, can you upload your full Mac Crash Report to the link I specified above?

Are there any actions(s) that you take when the issue occurs that you can share? Do you exit Roon on a specific screen? Or exit during music playback and then the crash occurs on next startup?

@noris

In my case Roon crashes only at startup. I keep Roon app open all the time but sometimes I quit the app and 3 out of 10 times when reopen, the app crashes. It never crashes if I open it after I reboot my Mac Studio which happens rarely as I keep my Mac running 24/7.

Here is the full process:

Most of the time I get this screen after the 4th Roon startup, then it shows up every time at startup unless I reboot my Mac:

Then if it crashes, I get this report from macOS:

If I press Reopen, then Roon starts fine. Roon has never crashed during playback, only during startup.

How do I save the Mac crash report? I have tried and can’t find a way to save it.

PS: Nevermind, I just recall how to get the crash report. I just uploaded it.

1 Like

@noris In March I first posted about this crash. Several months and versions on, but still no solution to this annoying problem.
It is the only application on my computer that crashes. It is also the only application developed with Mono.

I’m pretty sure that Mono framework is the culprit. I understand why Roon chose something like this but the Mono framework clearly doesn’t work well on current Macs (don’t know about Windows of Linux).
The developers probably spend a lot of time looking for these kinds of bugs. Not very motivating.

On a Mac use Xcode and Swift to build a stable frontend. The debugging time will be greatly reduced and we will have satisfied Mac Rooners (and developers).

1 Like

I expect that as soon as they can Roon will be bringing the Mac software in line with the Windows and Linux versions already running on native .NET.

1 Like

I posted earlier that updating my Mac mini M1 to the latest Monterey 12.4 Beta solved my crashing problems and I’ve experienced no problems since opening the Roon app. So there’s hope on the horizon.

Hi All,

Thanks for the feedback here so far. It sounds like the issue only occurs on M1 Macs, but it is not clear if all M1 macs on 12.3 or above are affected.

Are there any users who are running 12.3 or higher on an M1 Mac without issue? If so, this would be a good data point to have.

This too would be good to confirm if comfortable with testing Beta Mac releases:

Also, in an attempt to find commonalities between these setups, can you please generate a System Information Report and upload it to our Log collector for review?

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

Thanks!

Info sent, I hope it is useful. And to confirm I’m having no crashing issues using Roon as a remote on my Mac mini M1.

1 Like

I submitted a Support request separately before finding this thread. It looks like I’m in good company. The next time Roon crashes for me I’ll upload my Mac Studio’s crash report to the link posted above. Hey, misery loves company!

1 Like

I’ve just uploaded a crash report. Roon client crashed eight times in a row. The only way I could get it to reload was by restarting Roon Server. Normally, I can get the client to restart on the fourth or fifth attempt, but not this time.

I just uploaded my latest Roon crash report and System Information report to https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external. I hope this helps the team troubleshoot…

I have a similar problem…OSX Remote crashes and freezes the screen often requiring a force quit. As per the others, above, M1 Mac, OS remote, ROON Core on the network and all elements running the latest software versions.

So far it looks like the just-released macOS Monterey 12.4 update fixed this, although Roon still launches and connects pretty slowly (at least relative to my other apps). But hey, no more crashing!

2 Likes

I’ve also just installed 12.4 and Roon client loaded without crashing. One launch isn’t much by way of evidence, but I have my fingers crossed.

1 Like

Just bought M1 Air running OS 12.4. On my first attempt to open Roon (Roon Core on an Innuos Zenith) was informed I must download Rosetta. This I did after checking this thread and, after some trepidation… all working perfectly! Woohoo.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.