Roon Crashing on Startup, no changes since last Roon update, GUI unresponsive before crash

Core Machine (Operating system/System info/Roon build number)
Win10Pro Core Machine:
i9 9900k
64GB DDR4 RAM (4200mHz, 4x16GB)
2x GTX 1080Ti

That’s everything I thought pertinent. Music storage is in several locations, Tidal & Qobuz integrated. Usually fed by my NAS but currently being fed by my 14TB external hard drive until I get around to doing some maintenance (unrelated, has been fed by external hard drive for the better part of 2021 with no issues)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Everything has custom length ethernet runs going to it. Currently I have the Pi2AES on WiFi (a dedicated 5GHz band) as I was troubleshooting.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue

The thing wont stay open for more than a few minutes to test different audio devices. When I see it load however it’s my default group containing my Pi2AES which feeds my Holo May and my Soncoz SGD1, as well as a virtual audio driver which is used to feed my VU’s and Visualizer. Should be noted I have switched to just use Pi2AES direct instead of feeding it to HQPlayer, again for troubleshooting. I also feel it pertinent to note that of these two devices I have also attempted launching Roon with both devices disabled / powered down, again unfortunately with no luck.

Some time last night as I was doing a listening session (always groovy, complete Roon convert here, btw please update API I love tinkering :smile: ) Roon crashed suddenly and without warning, my first assumption was it didn’t like how much I was skipping around, though I haven’t had issues skipping chunks of playlists before, though it did skip 4,000+ tracks without issue and continue trucking so unsure if that’s the root cause.

After the application crashed, and to simplify troubleshooting steps (day job in IT Architecture, I usually don’t end up making posts, but I’m at my wit’s end…) here’s what I have done so far:

  • Checked with UAC enabled and disabled, no change.

  • Checked with firewall enabled and disabled, no change. Don’t think either of these are applicable to my issue as the app is crashing, not some other functionality.

  • Checked event viewer, latest logs indicate issues with loading ntdll.dll, which is used for NT kernel functions to the best of my knowledge.

  • Thus I ran an SFC scan to be sure, as I have other applications that utilize that dll file and none have had issues initializing it, and as the title suggests, the latest changes to my OS were a Windows update to bring me to latest version a few weeks ago, followed by the Roon update not long after. For the record, SFC scan showed no integrity violations

  • Rebooted a few times, rolled back windows update, reinstalled windows update. Again, all no change.

  • Checked Roon logs a few times, nothing there really stood out to me but I did catch that it failed to initialize my external hard drive that I’ve been using to troubleshoot, I also tried mapping it as a networked drive and disconnecting USB, no change.

  • Again of note, it stated drive availability is false, I have other backups run to that drive weekly of my various git forks with no issues, so I found that strange:

Here is a snippet of that info log that jumped out to me:

03/27 09:56:00 Info: [broker/locations/directorystoragelocation] initializing FileBrowser.Entry:  Oxenfurt, WD My Book 25EE USB Device : \File\Music, drive availability is: False
03/27 09:56:00 Info: [broker/locations/directorystoragelocation] drive is not available so disposing resources (if they exist): FileBrowser.Entry:  Oxenfurt, WD My Book 25EE USB Device : \File\Music
03/27 09:56:00 Info: [broker/locations] storage location backend (Folder:Name=:Location=FileBrowser.Entry:  Oxenfurt, WD My Book 25EE USB Device : \File\Music:Id=a5bcefb3-abe0-48b8-937a-42c8287b9111) offline reason changed to: DriveNotReady
03/27 09:56:00 Info: [broker/locations/directorystoragelocation] we'd like to keep this volume mounted: mounted:H:\
03/27 09:56:00 Info: [broker/locations] created enabled location, FileBrowser.Entry:  Oxenfurt, WD My Book 25EE USB Device : \File\Music
03/27 09:56:00 Info: [broker/locations] adding storage location: Folder:Name=:Location=FileBrowser.Entry:  Oxenfurt, WD My Book 25EE USB Device : \File\Music:Id=a5bcefb3-abe0-48b8-937a-42c8287b9111

I remember coming across an issue similar to this at one point, where removing the library and re-adding it resulted in it doing another scan and working properly, more specifically, doing that task without utilizing Roon’s GUI, but I can’t for the life of me remember where that is if I can try to clear something out to force Roon to “forget” my local library so I can attempt to re-add it? That is my hunch as to what may be the issue…

–Proofreading edit–
Scratch the above…upon further inspection looks like after the GET request it reinits and shows the drive is attached and available:

03/27 09:56:01 Debug: [broker/filebrowser/drive] availability on drive's volume changed: True: VolumeAttached[id:mounted:H:\,title:[H:] Oxenfurt,subtitle:WD My Book 25EE USB Device,mountdir:H:\]
03/27 09:56:01 Info: [broker/locations/directorystoragelocation] drive availabilitychanged: True, FileBrowser.Entry: [H:] Oxenfurt, WD My Book 25EE USB Device : \File\Music (it was False)
03/27 09:56:01 Info: [broker/locations/directorystoragelocation] drive is available checking to referencing fs provider and setting up dirwatcher: FileBrowser.Entry: [H:] Oxenfurt, WD My Book 25EE USB Device : \File\Music
03/27 09:56:01 Debug: [broker/locations/directorystoragelocation] drive path lookup took 1ms: FileBrowser.Entry: [H:] Oxenfurt, WD My Book 25EE USB Device : \File\Music
03/27 09:56:01 Debug: [broker/locations/directorystoragelocation] dirwatcher init took 0ms: FileBrowser.Entry: [H:] Oxenfurt, WD My Book 25EE USB Device : \File\Music
03/27 09:56:01 Info: [broker/locations/directorystoragelocation] attaching backend: FileBrowser.Entry: [H:] Oxenfurt, WD My Book 25EE USB Device : \File\Music

Not long after that, what looks like some more checking and verification on the various zones and their status / queues, followed by the last line of the log, which also happens to be the only warn as far as log levels go in the log itself:

03/27 09:56:22 Warn: [ui/slowness] widget recommendedartistgrid_pagegrid(1655) > stackpanel(2341) > stackpanel(2342) took 1788ms to _PreUpdate

The Tl;dr is:

Tried a bunch of stuff
No dice
Halp pls

Bump, I am really hoping to get this at least looked at if possible, or at least know what I need to do or provide to aid in driving this to resolution.

I have also uninstalled the application files for Roon and reinstalled it to no avail…I’m hesitant to do the uninstallation of both Roon and the Database as while I do have backups it may not be necessary if there is a simple fix that wont result in unnecessary time spent restoring from the backup.

Let me know.

I ended up uninstalling completely and reinstalled and then restored from a database backup from last week. All is well now. Cheers!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.