Roon creating spurious composer credits

Roon Core Machine

Windows 10 64 bit
Roon 1.8 latest build

Networking Gear & Setup Details

Ethernet to the router; Music on USB discs directly attached the machine running Roon

Number of Tracks in Library


Description of Issue

I don’t usually look at classical composer credits but did recently and saw that Beethoven is credited as composer on a number of pop and rock albums that I have. I will pick a couple of different examples:

  1. Rialto issued an EP called London crawling. Beethoven is credited as composer on all three tracks. He isn’t the composer on any of the tracks. My metadata tags do not mark him as composer so it has come from Roon. If I try to edit the album in Roon it says the album has no credits. Yet there the album is cluttering up the list of albums under the composer Beethoven. How do I clean up credits when there are no credits?

  2. The David Bowie multi-disc set Five Years. Again my metadata tags have no composer yet Roon shows Beethoven as the composer of all tracks. This time there are credits and sure enough Beethoven was there as composer so I unchecked the box. No effect. Album still shown by Roon as being composed by Beethoven.

How do I clean up this mess?

I’m no expert on Beethoven or David Bowie, but every great artist and composer wants to be named.

Look here:

in the middle of the page it says:

Composed By - Rossini* (track: 9-1), Beethoven* (track: 8-1), Edward Elgar* (track: 9-9).

After that would be The Rise And Fall Of Ziggy Stardust And The Spiders From Mars: The Motion Picture Soundtrack 8-1 Wendy Carlos- Introduction 1:06 by Beethoven.

Have you tried to remove using album editing or track editing? You may need to check both.

That’s good detective work.

This example troubles me less than the other one as I seem to have control over it. Although I said in my original post that unchecking Beethoven as a composer didn’t immediately remove the album from the list of Beethoven compositions, after I stopped and restarted Roon the album was no longer in his list. So for the many examples where Beethoven is in the credits, if I think the link is silly I can at least switch it off.

I will add another note about the Rialto case as it is slightly different.

I’ve edited the David Bowie album and unchecked the composer credit and that seems to do the trick. The update just doesn’t seem to be instant…

I will be adding an additional note on the Rialto case as that is slightly different.

1 Like