Roon cycles through all songs, not playing any of them

Roon Core Machine

Synology DS918+
Intel Celeron J3455 4GB RAM

Networking Gear & Setup Details

Too much to list. The network is working fine and is 100% not the issue.

Connected Audio Devices

(The first setup is the one I have problems with. It’s the only one written out in detail.)
Beyerdynamic DT1990 pro connected to dell XPS 9510 (running windows 11 Pro 21H1 (22000.348)) via an SMSL SU9 dac and a THX AAA 789 amp.
Apple iPad pro (gen 3)
Apple TV connected to a Samsung TV.
Desktop windows 10 Pro 20H1
Klipsch in ceiling speakers.

Number of Tracks in Library

I didn’t find any track counter in Roon. I’m estimating that I imported a few hundred from my library and a few hundred from Tidal.

Description of Issue

Whenever I try to play a song using the default output of my XPS, Roon cycles through all songs in the selected album very fast, not playing any of them, and returns to the “Nothing playing” status.

All other devices I own work perfectly and are networked in the same way. I’m guessing the problem lies with the audio drivers Dell includes. It’s a terrible program called Waves Maxxaudio Pro and it’s unremovable.

I think that just switching this driver out for a standard Realtek one like on my desktop would make it work but that’s not an option because it’s a custom solution. So I just turned off the auto start for that program and disabled any audio “enhancements” it made. I know these settings works because any program other than roon works perfectly. Of course I tried every possible combination of settings, restarting Roon, restarting the core, restarting my PC, plugging the amp directly into the 3,5mm, etc… But by far the weirdest thing is that Roon makes no problem of just using the onboard speakers.

Based on all this testing I’m pretty certain the problem lies with roon. I’m guessing it’s some obscure setting I don’t know of or maybe an edge case caused by these weird dell drivers the makers of Roon didn’t take into account.

One last thing, maybe unimportant but it’s something very similar so it might be helpful: I remember seeing this exact kind of behaviour on Spotify a year or so ago on a completely different laptop. The problem was that the sample rate selected in the driver settings was too high. Using 24 bit 48000Hz fixed it. I also tried changing this to no avail.

2 posts were split to a new topic: Roon Cycles Through Older Files

I have made progress:

If I turn roon off, set the default output to my speakers (that worked perfectly if you recall), then start roon, play a song and switch to a different output while the song is playing it works perfectly. I need to go trough this dance every time I reopen the app so the problem is not solved. This is more of a stopgap.

Show us a screen shot of your Settings>Audio page. That may help us figure out what’s going on.

If the core is on your Nas it lacks power.

If your network is as you disscribed with many components read also this

The core is powerful enough because I am able to play audio on all (working) devices at the same time without issue.
Since other devices are working like intended the network is not at fault.
Also since messing with the driver settings makes it work a little means it’s a local problem. Since I don’t have this issue with any other audio outputting software it’s a roon problem.

(I meant to reply to fietser in the post above.)

I will do so once I get back home.

If you took some time to read the Roon knowledgebase you should find this.

What will happen if Roon Server runs on a slower CPU (such as Atom or Celeron)?

Roon Server uses a lot more CPU than any other audio software. You can read about why we have a Core and why it requires so much more CPU than other software here. While Roon Server will work fine on these slower CPUs, consequences of running on them potentially include:

  1. Stuttering or dropouts in audio playback

  2. Slow response for searching

  3. Slow loading of artist, album, composer, and work pages

  4. Longer startup and connection times for remotes

  5. Slower audio analysis for normalization/crossfading/other

  6. Slower import of new music

Overall, the experience will not be as good as it can be. You can fix this by running on a better-suited CPU, such as an Intel Core i3 or i5.

Really? The number of tracks should be shown on your Home page like this:

@fietser - while it’s true that the Core would perform better on a faster CPU, the symptoms being described by @Gilles_Van_pellicom are more likely to be caused by the audio drivers/setup of the audio endpoint on the Dell XPS 9510 connected to the SMSL SU9 DAC.

1 Like

Why do you assume I didn’t take the time to look over and consider your suggestion?
I read the things you sent me, came to the conclusion that this is not the issue and explained why I think so. I tried your suggestion as part of troubleshooting before I posted. I installed the core on my desktop (i7 6700k, windows 10 pro, 32gb 3200mhz ddr4, samsung something evo m.2) and the issue persisted.

Oh I was looking for a counter in the my library tab. 1282 songs. Thanks.

Here you go.

It looks as though you’re using the System Output device on your Dell. You could try the Realtek WASAPI device instead. Odd, though that you seem to have two Realtek WASAPI devices - I would have expected to only see one…

Those wasapi ones you see are a direct link to my audio devices, so the default output is ignored if I pick these. One is my onboard speaker, the other my su9. The ASIO one doesn’t work. Even if I pick the su9 directly via this method it doesn’t work. This is not something I set up.

So shouldn’t you be using the WASAPI connection to your SU9? That’s the one where trying different settings might prove to fix things, I think

Unfortunately this gives exactly the same result as using the default.

What have you got for the Advanced settings for that device?

@Geoff_Coupe @Gilles_Van_pellicom Thanks for you’re reaction. Not a tech guy just trying to help out.

1 Like

Here are the advanced settings:

And my driver settings:

I tried turning exclusive mode and/or enhancements back on but that just made the sound on my entire laptop worse or just crash.