Roon cycles through all songs, not playing any of them

The core is powerful enough because I am able to play audio on all (working) devices at the same time without issue.
Since other devices are working like intended the network is not at fault.
Also since messing with the driver settings makes it work a little means it’s a local problem. Since I don’t have this issue with any other audio outputting software it’s a roon problem.

(I meant to reply to fietser in the post above.)

I will do so once I get back home.

If you took some time to read the Roon knowledgebase you should find this.

What will happen if Roon Server runs on a slower CPU (such as Atom or Celeron)?

Roon Server uses a lot more CPU than any other audio software. You can read about why we have a Core and why it requires so much more CPU than other software here. While Roon Server will work fine on these slower CPUs, consequences of running on them potentially include:

  1. Stuttering or dropouts in audio playback

  2. Slow response for searching

  3. Slow loading of artist, album, composer, and work pages

  4. Longer startup and connection times for remotes

  5. Slower audio analysis for normalization/crossfading/other

  6. Slower import of new music

Overall, the experience will not be as good as it can be. You can fix this by running on a better-suited CPU, such as an Intel Core i3 or i5.

Really? The number of tracks should be shown on your Home page like this:

@fietser - while it’s true that the Core would perform better on a faster CPU, the symptoms being described by @Gilles_Van_pellicom are more likely to be caused by the audio drivers/setup of the audio endpoint on the Dell XPS 9510 connected to the SMSL SU9 DAC.

1 Like

Why do you assume I didn’t take the time to look over and consider your suggestion?
I read the things you sent me, came to the conclusion that this is not the issue and explained why I think so. I tried your suggestion as part of troubleshooting before I posted. I installed the core on my desktop (i7 6700k, windows 10 pro, 32gb 3200mhz ddr4, samsung something evo m.2) and the issue persisted.

Oh I was looking for a counter in the my library tab. 1282 songs. Thanks.



Here you go.

It looks as though you’re using the System Output device on your Dell. You could try the Realtek WASAPI device instead. Odd, though that you seem to have two Realtek WASAPI devices - I would have expected to only see one…

Those wasapi ones you see are a direct link to my audio devices, so the default output is ignored if I pick these. One is my onboard speaker, the other my su9. The ASIO one doesn’t work. Even if I pick the su9 directly via this method it doesn’t work. This is not something I set up.

So shouldn’t you be using the WASAPI connection to your SU9? That’s the one where trying different settings might prove to fix things, I think

Unfortunately this gives exactly the same result as using the default.

What have you got for the Advanced settings for that device?

@Geoff_Coupe @Gilles_Van_pellicom Thanks for you’re reaction. Not a tech guy just trying to help out.

1 Like

Here are the advanced settings:



And my driver settings:

I tried turning exclusive mode and/or enhancements back on but that just made the sound on my entire laptop worse or just crash.

I would try updating your realtek drivers, there are multiple issues with realtek and all sorts of programs, including roon.

Try Ged’s suggestion of seeing if there are more recent drivers. I have Realtek audio hardware on my desktop PC (on an Aorus motherboard), and I can’t help but notice that I am seeing different settings available in both Roon and the Realtek Windows driver to you…

Edit: sorry, I accidentally posted the wrong Windows drivers… Here’s the actual Realtek Windows driver - and I have all the boxes checked - and no crashing of my PC…

Roon 1887

My drivers get automatically updated by the dell software. It’s the latest version. I can’t check the exclusive control box because it messes with a lot of software I use. Signal enhancements are off because the dell maxxaudio drivers “enhancements” make everything sound stuffy and boomy. The problem is those custom dell drivers but I can’t remove them.

Nobody has an idea anymore?

I read through this quickly but… Roon cycling through songs like you describe usually means the Roon Bridge is reporting an issue with the play out buffer (which can be caused by many things including faulty drivers, bad cables to DAC, etc.).

You really should be using the WASAPI driver to the su9. I’d ignore trying to get this working via the system mixer and focus on the WASAPI driver. Having exclusive access to the DAC will give the best sound quality as well as eliminate contention for the device which may cause Roon fits.

What do you mean by this? What are you actually doing?

You mean set default in windows? Windows default should be something not the su9 and use WASAPI driver exclusive to the su9 for Roon. You enable this in the Audio settings in Roon (Realtek(R) WASAPI) and disable the “XPS 15”.

Switch in Roon or Windows?

I really do think exclusive mode will get this stable. Then, if you want to use the Windows mixer we can go back and troubleshoot that. But, as another poster already stated, those Realtek drivers are garbage and probably the root of the issue. I’ve never had a “stable” audio system on any windows system that uses realtek (and this is well before I knew anything about Roon).