Roon database backup isn't working anymore [Fixed in b274]

Hi everyone!

I can’t backup my roon database anymore. My last successful backup was on September 29 (2017). During the (unsuccessful) backup attempts everything seems to be working fine and after them I do get the message “last successful backup at… (plus the correct date and time)”, but nothing (new) shows up in the backup folder. If I try a new folder (either on my internal SSD or on one of my external SSDs), the folder always remains empty. However, if I right-click on the folder to get information about its contents, it says that the size of the “empty” folder is 1.64 GB. (My library contains about 16.500 tracks.) If I try to delete one of the older backups, I get the message “delete failed - check storage location”. Could someone please help me solve this problem?
Any advice will be greatly appreciated.

1) iMac Specifations

Sorry, I’m new here and I’m not quite sure what you mean. Have I made a mistake? Haven’t I flagged my post properly?

Yes your post is flagged correctly The roon guys will no doubt help out soon

Hi @Hans-Willi_Zerres ----- Thank you for the report and sharing your feedback with us. Both are appreciated.

Moving forward, to help aide in our understanding of this behavior you’re reporting to us, may I very kindly ask you to please provide the following:

  • Since noticing this behavior have you tried changing your “backups” location? Based on your screenshot(s) it appears that you “backups” folder is located in your “music” folder, have you tried changing this?

  • Can you please confirm that you have the necessary “read” *and “write” permissions enabled for the “music” folder.

  • I have went ahead and enabled diagnostics on your account which will generate an automated reported containing your logs, which will be delivered directly to our servers when your core machine is online next. In light of this, may I kindly ask you to reproduce the issue and the note the time when it occurs.


Yes, I have tried changing the backup location (on internal SSD and on three different external SSDs), but to no avail. I also have the necessary “read” and “write” permissions.

I reproduced the issue twice - at 17:55 (music folder) and at 18:07 (downloads folder). In both cases I get the same result (two “empty” folders with a size of 1.64 GB each). Roon can’t find the allegedly successful backups.

Hi @Eric

I have the excact same behavior on my MacMini High Sierra. I have found out that the backup folder and files seems to be invisible.

When I in Terminal use “defaults write AppleShowAllFiles TRUE;killall Finder” I can see the contents of the backup folder. I think that roon is not able to see the files because of the invisibility even that the backup actually has been run.

Hi @Hans-Willi_Zerres ----- Thank you fro following up with me, confirming that the report has been received and is in our queue to be evaluated by a member of our tech staff.

Once i have received an update on my report, I will be sure to share the team’s thoughts/findings with you asap. Your patience is appreciated!


Hi @Audioholic ---- Thank you for chiming in and sharing your feedback with us. Having your observations from your troubleshooting is very appreciated!

As I had done for Hans, I enabled diagnostics on your account as well so we can get some deeper insight into this behavior. Please reproduce the issue, note the time when it occurs, and I will attach your diagnostics report as well to my “support feedback” request.


Hi @Eric
I have created a backup at 19:23:12 and finish at 19:25:45 with the same result as before.

Great, thanks @Audioholic! We’ve received the diagnostic print out!

Once I get some feedback from our techs I will be sure update this thread in a timely manor. Your patience is appreciated!


Hi @Eric,

thank you so much for your speedy replies. In the same way as Audioholic (i.e. by running the script “defaults write AppleShowAllFiles 1” in Terminal) I, too, can make the hidden files in my backup folder visible, but Roon still can’t find them and claims the folder is empty, but only if the new backup is the only one in the folder. If I add a new backup to a folder that already has older backups in it, the new one shows up in Roon, but not in the Finder (unless I use the “ShowAllFiles…” script). In both cases I can’t delete any backups in Roon. (For obvious reasons I haven’t tried the “restore” option.)

Roon can’t find yesterday’s backup in this folder (internal SSD). There is only one (hidden) backup in it.

Roon finds all three backups in this folder (external SSD), two older ones plus the one I ran yesterday. However, yesterday’s backup is not visible in the Finder (without the “ShowAllFiles…” script).
Folder with 3 backups

This is what happens if I click the delete button for any of the backups - no matter if they are (made) visible in the Finder or not.
Delete failed


My Roon Server (Mac Mini, late 2012, Sierra) was switched off (on October 14th) for a week (away on holiday). When I switched back on the latest Roon update was applied. Backups since then are not showing up in Roon - they are being stored in a hidden folder - see screenshot.

Hi @DuckSoup ---- Thanks! I have enabled diagnostics on your account as well :microscope::sunglasses:


All ---- Please be advised that our developers are aware of the reported behavior and will be investigating accordingly.

Once my report has been updated and passed back, I will be sure to provide an update on the team’s progress in a timely manor.

Your patience is very appreciated!

Thanks a lot for your support.

@support I’m having the same or similar issue on a Mac mini. No backups showing up since build 262, last date 10/17. First noticed the problem as a constant Dropbox “churning”, unusual because I’ve set the backup to run daily in the middle of the night. Wanted the daily backup to be small so it would complete by morning.

A manual “forced backup” showed up as canceled after around a 18 hour run. Giving the “forced backup” another shot today.

I hadn’t discovered the issue previously because the Mac mini normally runs headless.

Thanks for your help.

@support I am having the same issue. It appears Roon is now performing backups to a hidden folder, now with root privileges.

I am running a Linux install of Roon server. The hidden directory is not shown in the Roon backup feature.


My scheduled backups are no longer running at all! It should run automatically every 4 days but didn’t
I had to manually force a backup.

Now that the manual back up is finished I see that the folder is also hidden … what’s going on. Is the backup function still working or not? @support

Hi everyone,

I really don’t mean to come off as impatient, but may I ask if there’s any news on the issue reported and described in this thread? Just like @stevev1 and other users, I’m starting to feel worried that the backup function might no longer be working AT ALL - despite the hidden folders. Needless to say, that would be an extremely serious issue…

Any help or advice will be greatly appreciated.