Roon dead after attempted OS reinstall

Roon Core Machine

Roon Nucleus + Rev A

Networking Gear & Setup Details

Ubiquiti UDM Pro
Ubiquiti 4-port switch

Connected Audio Devices

None yet.

Number of Tracks in Library


Description of Issue

Purchased this Roon used last summer but didn’t attempt to connect it until this week. The unit initially showed up on the network but was non-responsive to the Roon Remote app. I attempted an OS reinstall of the Nucleus through the web interface, but it stalled and had not restarted after 6 hours. It appears that the OS reinstall failed. I connected an HDMI monitor and keyboard but the HDMI output displays nothing. The power light does turn on, however.

Sounds like a possibly dead network interface to me. Did you never try out if it worked after buying it used? Risky strategy.

Yeah, dumb mistake but personal life got in the way and here we are. Now I’m $1500 in to a dead unit. Any suggestions welcome.

If you are lucky it might be just a dead SSD, it would not be the first in a Nucleus. You could try replacing that and trying to reinstall ROCK. If that boots / shows HDMI output, let the support folks know here in the forum so that they can flip the switch to enable the special Nucleus software (for heat management) on your device; they can do that remotely.

Or possibly just some connections got loose during shipping, so try reseating the RAM and reconnecting the SSD and possibly HDMI connectors

Do you see any lights on the ethernet port?

You can try this:

Or try this (you can try to install ROCK and then have Roon Labs push out an update to get the Nucleus OS):

Thanks for the ideas. The Ethernet port does display lights, but since the HDMI port does not display output I am unable to proceed further. I tried the resetnetwork command using the keyboard but it does not appear to have worked.

OK. I’ll try reseating everything tonight. I went ahead and flashed a USB stick with ROCK in case the HDMI port starts producing output.

I opened up the unit and re-seated the RAM and other connectors I saw. No change in the system behavior.

:frowning: This does not sound good at all if there is not even an HDMI output. Even if the disk was dead I suppose it should at least get to the BIOS output

Is there a service process for used units?

Not if the motherboard is dead.

That’s what I meant, if just the disk was dead, it should (and in this case it would be an easy DIY fix, but doesn’t look like it)

@support can advise

Was there any visible damage when you opened the unit, like in the thread below?

I didn’t fully remove the mainboard, but there was not any obvious damage like in the thread you provided.

@support I would love some help here. It’s been a frustrating first few days in the Roon ecosystem.

Hi @Stephen_Zoepf,

Unfortunately, no output via HDMI does mean the motherboard is our likely culprit.

I will send you the template for an RMA repair. Please note, warranties are non-transferrable and there will be a cost associated with this repair.

I will message you momentarily.


Thanks for your help, Wes.

You are most welcome. Your ticket has been created and someone will be in touch.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.