Roon didn't start after install on my laptop

Hi I am running Roon Server on my mac mini and i use multiple remote (iPad, Nexus 7, Window Desktop) and I installed another Roon to my lap top to use as another remote.
However, I have a problem on my new installation.
After Roon Banner was shown up and Roon Process was killed. I looked into the Roon Log and I found some information why Roon process is not working. The log says there is exception during running up roon process below:

-[ BROOSCRIPT EXCEPTION ]-------------------------------------------

Exception Message: Object reference not set to an instance of an object
at C:\sooloos\sooloos\Client\ui\profiles.broo:6 [4d76e3:0e0f] global script

–[ INNER EXCEPTION ]------------------------------------------------
Inner Exception Source: Broo.Runtime
Inner Exception Type: System.NullReferenceException
Inner Exception Target Site: Equation.GetValue
Inner Exception Message: Object reference not set to an instance of an object
Inner Exception Data: none

My laptop’s Operating System is Windows 8.1 Korean 64bit.
My laptop is a LG Gram Notebook with i5-4200 with 8G Memory and Intel HD Graphics.


Since I updated to 64bit Roon on Windows I’ve seen this a few times on Roon startup. I don’t know why it fails but for me at least rebooting the PC recovers it.

@Carl i am afraid it happens again after i reboot my lap top .
Furthermore i uninstalled Roon, reboot and re-install , But it didn’t work

It was worth a shot, I’ll leave a flag here so @Mike we pick this up.

I wonder it is under investigation or not. by Roon developer…

Hey @DAEGUN_Park - sorry, I think I missed this one. I’ll be in touch via PM and we’ll get some information to figure this out.

Stand by!

Hey @DAEGUN_Park – on the machine that’s having this issue, can you find your Roon Folder, rename it to something else like Roon2, then reinstall from scratch one more time and let me know if you have any luck?

We have the logs and we have an idea of the issue, but we’re not sure how you got into this state, so we want to try this first, before looking into this further.


I renamed folder and reinstalled Roon But i don’t think i got luck . Same error was shown on newly installed log.


Ok, thanks for the update @DAEGUN_Park and sorry for the ongoing issues here.

Just to confirm, this is still the same laptop described in your original post, right?

Your other devices are working properly? Does the laptop and the Windows desktop have the same version of Windows? Same language packs? Fonts?

I’m going to get some more feedback from our developers, but in the meantime, it might be worth looking into distinctions between the Windows system that is working and the system that’s having this issue. I’ll be in touch as soon as I have some more feedback here, so thanks in advance for your patience.

Hi @mike

All other devices work fine . Desktop and laptop have a different Window version. Desktop uses Windows 10 but labtop uses Window 8.1 K .