Roon disconnects from NADAC+Player

Roon Core Machine

NADAC+Player

Operating System: Version 1.0 (build 227)

Roon Server Software: Version 1.8 (build 1021)

Merging Technologies Software: Version 1.1 (build 93)

Roon Database & Settings: 100% of 107 GB available.

Networking Gear & Setup Details

TELSTRA SMART MODEM GEN 2 (wifi Modem Router)
Modem Make Model: Technicolor DJA0231
Version Egyptian Blue (20.3.c)

  • DHCP Enabled
  • Wifi 2.4GHz & 5Ghz, Access Points Enabled

Connected Audio Devices

The NADAC+Player is a music streamer with built-in Roon Core, a DAC and streamer. It requires ethernet LAN connection as well as wifi to work with Roon app. Music is outputted via balanced XLR cables to an integrated amplifier.

Connection chain: Wifi modem Router > Sotm SNH-10G Network Switch > NADAC+Player > Amplifier

Number of Tracks in Library

Using Tidal (90 Million tracks)

Description of Issue

  1. Roon randomly disconnects from the NADAC Player and is unable to reconnect. With continuous attempts - restarting router, restarting player, restarting Roon Server Software sometimes successful. It feels like pot luck if it finally reconnects.

  2. Roon logs out Tidal randomly. I’ve noticed on two occasions, when it wants to play a song that Roon says ‘can’t find music from your library’ its usually when Roon disconnects from the Player. When I manage to get Roon to reconnect, i would need to log in Tidal.

Note: I used to have a Synology NAS connected but have since turned it off for troubleshooting. I have Reset the Roon Database & Settings.

Allan, a couple of questions (and I am not familiar with the Merging products other than what I have read).

  • Have you checked your cables and the switch to determine if you may have a poor cable? It is not clear if you cannot see Roon on your network or if there is an issue with the NADAC+Player.

  • Have you contacted Merging with your question as it may be related to their operating software also, and how Roon’s and Merging’s software interact with each other.

Hi Robert, thanks for your response.

  1. I’m using a high quality ethernet cable which has worked fine in another setup.

Roon is visible on the network and to the nadac player. The issue is that it randomly disconnects and unable to reconnect (easily) without restarting everything and a lot of fussing.

  1. I have queried this issue with Merging and they have asked that I contact Roon.

Separate to the Roon disconnection issue, Tidal gets logged out randomly then has trouble reconnecting and logging back in on repeated retries. To finally be able to log Tidal back in, I had to restart the Roon server. What could be causing Tidal to log out by itself inside Roon app?



This looks like a network issue somewhere in your system, but I am going to tag @support who may want to ask some additional questions and also may want to look at your logs.

Thanks Robert. I think network issue is likely but that’s not to rule out that the nadac player may be problematic (the unit new btw!)

I would be great to get some guidance to modem router/wifi settings or at least identify what could be causing the issues.

I’m not network savy, so assume the most basic of all problems :sweat_smile:

Cheers

Roon core inside NADAC+Player.

Roon Server Software: Version 1.8 (build 1021)

Merging Technologies Software: Version 1.1 (build 93)

Roon Database & Settings: 100% of 107 GB available.

Networking Gear & Setup Details

TELSTRA SMART MODEM GEN 2 (wifi Modem Router)
Modem Make Model: Technicolor DJA0231
Version Egyptian Blue (20.3.c)

  • DHCP Enabled

Connected Audio Devices

The NADAC+Player is a music streamer with built-in Roon Core, a DAC and streamer. It requires ethernet LAN connection as well as wifi to work with Roon app. Music is outputted via balanced XLR cables to an integrated amplifier.

Connection chain: Modem Router > TP Link Deco Mesh Wifi > Sotm SNH-10G Network Switch > NADAC+Player > Amplifier

Synology DS916+ NAS connected to Modem Router

Number of Tracks in Library

Music Library on NAS 47,000 tracks

Description of Issue

When adding ‘Music Storage Folder’ from my NAS (using either smb or \host\share), Roon remote disconnects from the NADAC Player. Upon re-connection the syncing of music from the NAS failed. Also on re-connection, I would have to log back into Tidal inside the Roon app.

The music folder on the NAS is shared on the network and is accessible by devices such as Sonos and iTunes and without any issues.

I think the problem has something to do with my NAS settings and Roon🤔. Does anyone have any idea what may be causing this issue with Roon?

Cheers

Hey @Allan_H,

I’ve merged your topics into one, as we require 1 post per topic in the community.

Our team enabled diagnostics on your account, but wasn’t able to pinpoint any errors pointing towards Roon. After discussing with the team, this seems like it could be ravenna related through NADAC.

If possible, I would contact the Merging+NADAC support for next steps.

My apologies here! Certainly, let me know if you have any additional questions.

-Ben

1 Like

Thanks Ben for your advice.

Cheers