Roon discovers nad 3050 le only as airplay device

Roon Core Machine

Roon Core Server on Mac mini M1, Late 2020, 16 GB RAM, Ventura 13.2.1

Networking Gear & Setup Details

Netgear Orbi 85 router
Netgear Voice Modem
One access point. No MESH network.
XFinity High Speed network in excess of about 600 mbs download
MDC-2 BluOS Module D, hard ethernet connection to router
Apple Mac mini M!, hard ethernet connection to router

Connected Audio Devices

Mac mini M1 connected to Cambridge Magic 200 DAC via USB
Cambridge Magic 200 DAC output to NAD 3050 LE using unbalanced line outs
Roon sees Cambridge Magic 200 DAC connected to core, and is enabled and selected as audio source.
Set NAD 3050 LE to Line input to access this source
Play primarily Tidal MQA Streaming

Also have Samsung 4K TV connected to HDMI eArc to send TV sound to NAD 3050

MacBook (Intel based) used as Roon Remote for control of core
iPhone 13 used as Roon Remote for control of core

Number of Tracks in


112000 tracks on MacMini M1

Description of Issue

Roon Settings, audio, show NAD 3050 only as an AirPlay device, under Other Network
Roon Settings, audio, show Cambridge Magic 200 connected to core.
Why is NAD 3050 LE not showing as connected to Core?
I have disconnected Cambridge DAC and Roon still does not show NAD 3050 as connected to Core
I have tried connecting MacMini M1 outputs directly to Core with no success (via USB C, optical, coax)
Would like to connect MacMini M1 core directly to NAD 3050 and employ its internal DAC, vice using Cambridge.emphasized text

Have tried factory re-set, updated to all latest NAD 3050 LE and BluOS versions, and re-booted modem and router several times, with no success in getting NAD 3050 LE to show as connected to Core in Roon

have a quick read through this. It might help.

Thanks, already read that. Tried everything mentioned in that post, which is closed.

Note that there is currently an issue with the latest BlueOS updates that Bluesound is working on fixing. This is affecting Bluesound, NAD, and probably other devices. This thread has all the details and at the end a workaround that might help:

Tried reboot of Roon Server Core on MacMini M1 and it did not resolve issue.

It won’t but as said it’s and issue BluOS side nothing Roon can do. Others have managed to find older firmware and roll back to sort it. If you go through some of the many other posts on this you will find what they did to achieve it.

Why should I have to search for old firmware? I guess I will wait for next release

You don’t have to but it’s a way to fix it, BluOS dropped the ball here. If you’re happy to wait then wait. But they don’t tend to rush out releases.

I’m just chiming in to to say I have the same issue with my NAD 3050 le. I don’t expect a fix from the roon side, so I’m also waiting on BluOS.

Hmmm. My C 3050 LE is still working. But I haven’t power-cycled it since installing the update. Maybe I shouldn’t.

All I have connected to it is Roon, over WiFi. Planning to add HDMI from my TV, and S/PDIF optical from my CD player. Not that I ever play CDs. Waiting on cables.

Hi @Robert_Connors,

Thank you for your patience.

As other users have mentioned, only Macs pre-2016 will have an optical output available through the system output. If you’re not seeing the NAD 3050 via USB, then please share a screenshot of the Audio Midi Setup app (Applications → Utilities) on your Mac Core. It’s like a system output issue. I also recommend refreshing RAATServer.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Please let me know if that helps.

Still not working… Bumping to keep the thread alive. Supposedly chatting with NAD or BluOS will have them revert your firmware to make it work, but I’ve been too lazy to do so.

I worked with BluOS support and they remotely reverted the software to previous version (45), and then I was able to update to 46 through usual process. Problem resolved.

Well it is until you have to factory reset and you’re back to square one. NAD and BluOS seem to be dragging their heals on this only been updates for the nodes so far to properly fix the issue. Pretty poor considering it’s of their making and getting on for two months.


I’m on my “Free Trial” period for Roon and my NAD C700 is not showing up as Roon ready. (My Powernode 2 in the bedroom is though…). This free trial isn’t going great so far, I can tell you that.

1 Like

In all fairness, it’s Bluesound’s problem, not Roon’s though.

Getting an older version of the firmware from them should fix it.

1 Like

My original problem was caused by me setting a factory reset…

Yes, totally get that… but it still gives me pause (when considering a full subscription after the trial period) due to lack of a tighter and seamless integration.

Indeed, if you are invested in BluOS devices, I’d be careful, too. So far everything can be fixed at made to work, but does involve more effort than it should.

1 Like

I sent a support request to NAD and they were able to remotely revert my C700 to the older firmware. The device now shows up and is usable as Roon Ready. :slight_smile:
Very happy with the quick fix from NAD :pray:

Now currently blasting Judy for all the world to hear!

1 Like