Roon DNS cache problem after STi5 upgrade to 2.6


(Andrew Gillis) #21

OK I’ll connect from remote and see whats going on.

go to smallgreencomputer.com and click on contact us. I can give you info in what you need to do.


#22

I assume this message was for Stampie. When you’re done I’d like to do the same thing using Team Viewer.


#23

Sorry Andrew, I can’t find a ‘contact us’ option on sonicorbitor.com page - Help just points to forums and FAQ doesn’t have it. I can click on the SGC icon and goto your website - is that what you mean?


(Andrew Gillis) #24

sorry smallgreencomputer.com :slight_smile:


#25

Thanks to Andrew @agillis for investigating this problem on Friday evening.

Unfortunately, the problem was not resolved, and Andrew’s conclusion was that something is wrong in Roon, but he couldn’t work out what.

Therefore, I would be grateful if Roon @support would now take a look at the problem and help me resolve it.

many thanks
Nick


(Andrew Gillis) #27

i was doing some more testing over the weekend with a NAS I have here and I found some ways a NAS can be configure that can cause it not to be resolved by name.

Press the upgrade button again on the sonicTransporter and reboot. I added some more code that takes care of this situation.


#28

Thanks Andrew @agillis. I did an update as requested, and although it did not solve the problem, I am now getting a more useful error message.

Instead of ‘unkown error’, I am now getting “Could not connect to share: Host not found”.

Btw, I have confirmed that my master browser is in fact set to my router, and the only other device I have that uses the \DiskStationPlus\music smb address (A BlueSound Pulse Flex) is working fine. The browser service is disabled on my 2 windows 10 devices.

Let me know if there is anything else I can try
thanks
Nick


(Andrew Gillis) #29

OK I would be happy to connect again and try to figure it out. Send me the usual info via email.


#30

I’m interested in the solution here, as well. After updating to 2.6, my sonicTransporter i5 is no longer able to resolve the name of my NAS (“NASNAME”). Prior to the 2.6 update it worked fine.
It also works fine if I replace NASNAME with it’s IP address. And I’m able to mount smb://NASNAME from my iMac directly. Thanks for the email response yesterday, Andrew.

From the Roon Client under Settings (sonictransport) > Storage:
\NASNAME\Music
This drive is not available. Check the drive or edit this folder if it’s been moved.

From the RoonServer Diagnostics page:
04/18 19:07:50 Debug: [roon/cifs] returned 1: mount error: could not resolve address for NASNAME: Unknown error


#31

Unfortunately, Andrew was unable to solve the issue when he connected to my STi5, so I have had to stick with using IP address for now.

It is worth carrying out another update of the ST, as Andrew did has made some changes since 2.6 has been available, and they might solve the problem for you.

@agillis, Hi Andrew, it looks like I’m not the only person with this problem…
regards
Nick


(Andrew Gillis) #32

Yes it looks like something to do with Windows networking (SMB) on your Synology. I would recommend upgrading you NAS to the latest software to see if it resolved the problem.


#33

The NAS software is already up to date, so nothing to update to at the moment. We’ll see if the next update makes a difference - I have my doubts though.


#34

Thanks for the help, Andrew. My issue was fixed. Simply changed the NAS host name from “NASNAME” to “NASNAME.local” in the Roon Storage settings and that did the trick.


(Alain Robillard-Bastien) #35

I had the same issue, and this solution worked! :slight_smile:


(Ross Frank) #36

I have had the same problem for 3 days now. I have tried every permutation of the ip and smb addresses, including the addition of .local. I simply get “drive not available”, or “Error loading folder - not available”. I can see and access the NAS form any other device.

SonicTransporter i7, Drobo5N NAS.


(Andrew Gillis) #37

Contact Small Green Computer for support if you are still having problems.


(Ross Frank) #38

Thanks to Andrew For fixing my problem, in person remotely!


(MOHAMMAD EL RAWAS) #39

facing the same problem, i had simply to reboot the sonictransporter and i can play my music again but V2.5 is still there.


(Andrew Gillis) #40

Did you follow the 2.6 upgrade procedure here?

http://sonicorbiter.com/docs/upgrade25