Roon does not any longer Scan automatically

@support: Im am using Roon an with the following components |NUC8i7BEH, 8GB RAM,128GB M.2 SSD

Im using Ethernet with CISCO Switches

Today i wanted to import some new music. Normally roon recognizes immediately a album and shows it in the roon overview. Today it is not working (the watching for new files in real time is activated). see below

The only way to force the rescan manually

What is wrong? I did no changes. I do not want manually for force a rescan . I want to have it again in real time.

Hi @CTH,

If you reboot the Core machine and add new content to the watched folder do you experience this same issue or do things import right away?

Hi Dylan,
I rebooted the core machine and added new content. But there is no change. It is necessary to start the scan manually

One additonal information: Before i used the roon on a synology nas on which the music has been also stored. Afterwards i bought the nuc and the music is as before stored on the NAS. Maybe roon can not scan the music because it is not local stored?

Hi @CTH,

Since experiencing this have you also tried rebooting the NAS?

Hi Dylan,
Today i rebooted the NAS and Again the roon core no change. I forced the rescan but automatically recognization is not any longer possible

Hi @CTH,

Can you verify what this setting is set to for this watched folder? Are things still not automatically syncing after the time set here?

Hi Dylon,
Yes i have the same setting. I did not wait 4 hours whether the System is syncing afterwards.

Was there a firmware or software update on the NAS? I keep my music local to the Core and use the NAS only as a copy of the music as NAS’s don’t necessarily report file structure updates timely. Are you using ROCK or Windows as the OS?

See this previous post for more info:

Currently there was no firmware / software update on the Nas. I use Rock as the OS.

Hi @CTH,

As a test, it would be good to know if this behavior occurs only with the NAS or if it occurs with any watched folder. This would help us narrow down where this behavior is stemming from.

If you connect a USB drive temporarily to the Core and add music to it do you see the same behavior occur or does it scan automatically?

Hi, I am unfortunately not a very technical guy. I plugged in the nuc a USB. I could find the USB Flash in Roon but unfortunately i could not find the USB flash in my Windows OS / Network. For this reason i am not able to test the transfer of the files. Any Ideas how i can find the USB Flash in the Windows explorer?

Following this one, as my install has started to do this as well. I generally just restart the core every few days after I have added music, and see it has not appeared. Then it does the auto scan and fixes the library. Then from time to time if I add more than one album to my watched folder they don’t all show up automatically but then all do when I restart and rescan.

Hi Larry,
If i restart the core and start automatically the scan it works. The point is that obviously the automatic recognition of the watched folders does not any longer work. Maybe due to the point that my music is on a network folder (NAS)

Same behavior with me, or, if I go to the “force rescan” section. I restart my computer every few days and Roon restarts with it, so it’s not that big of a deal. All my music is also on a NAS connected via Ethernet to a mapped drive. I noted in my setup that the “automatic rescan interval” is not an option via my NAS, perhaps that feature is only available if the drive is connected directly to the core computer.

Hi Larry, It seems to be an issue with the NAS. I have the nuc in the server room and it is connected via switches. Now roon does not recognize whether a change happen or not. Before i had the roon Core on the Nas installed and the automated recognition was no problem. Maybe it would be better to connect the Intel nuc directly with the NAS (ethernet). Are you connected directly with the NAS or Via switch?

Hi @CTH,

This article will walk you through doing this. If you follow the instructions here and still have issues please let us know!

I have my install on a workstation PC which doubles as my home computer. It is in my office on a desk, but the NAS is elsewhere in the home along with other storage devices connected to the network. There is one switch in between, a powered one, so perhaps that is the issue, although I have had it set up this way for a couple of years now. I just recently disabled iTunes support in Roon and switched to the watched folder being my network drive instead. That’s probably why I did not notice this issue previously. I only made that change a couple of weeks ago. I will continue to monitor my situation, and I hope support get yours fixed as well.

Hi Dylan,
Sorry for the late reply. With the USB it works but not with the NAS…

Any ideas what can be done?
Best regards

Hi @CTH,

Thanks for confirming that things work okay via USB. Since this is the case, it seems as though Roon is scanning appropriately, but since it’s not working with the NAS, the problem likely lies in the communication between Roon and the NAS.

Around when this started occurring was there any change at all to your networking setup or the settings on the NAS?

Can you confirm what model switches these are? Are they managed switches? Have you tried rebooting them as well during this process?