Roon does not detect the RoPieee on Wifi

Hi there,

I’ve installed Roon this morning on a Pi 3 B+.
Everything went smoothly and it works perfectly when the Pi is connected via Ethernet.
I did set up the wifi as I read in other threads here.

The Pi is connected to a USB DAC, also.

But, as soon as I unplug the Ethernet cable though, the device is not visible in Roon anymore. I tried rebooting it without the Ethernet cable, to see if it would pick up the Wifi but it does not.
With no Ethernet, I can’t access to ropiee.local or the IP.
I tried with the 2.4 GHz and the 5 GHz signal.

I sent Feedback, here is the number : 55105ec181200612

Thanks in advance for the help!

When you enable wifi then reboot you have to go back in and setup the SSID and password to use IIRC. Then you can restart again after applying the changes. Remove the LAN after it is shuts down to restart

Hey, thanks for the quick reply. This is what I had done.

I found the answer here in the end: New ropieee install and wifi

Added the network config through ssh in /etc/wpa_supplicant/wpa_supplicant-wlan0.conf and now it is working.
Also for some reason nano was not working so I had to play around with some vi, which I had not done in some time.

Here is what I did, if it can help someone:

ssh root@ropieee.local (password is root)
vi /etc/wpa_supplicant/wpa_supplicant-wlan0.conf
nano /etc/wpa_supplicant/wpa_supplicant-wlan0.conf

Add your wifi config this way:

ssid=“wifi name”
psk=“wifi password”

Save and quit, then reboot the Pi with the reboot command. And it will be working like a charm.


cant say I like vi and always takes me a bit of a google to recall what to do sometimes. I cant recall if nano is on the build or pico is another - maybe @spockfish Harry can config. Sorry I would check but I’m overseas for another week so ropieee builds in my luggage.

Ah it’s okay, a bit of vi won’t hurt that much. Google is here to help and everything works perfectly now. :slight_smile:
Safe travels!