Roon does not find Hqplayer

After the latest Roon update my friend, who has Roon on a Windows 7 computor, has the problem that Hqplayer does not play! The message is “Hqplayer may need an update” but he is running the latest Desktop version ( Hqplayer is running on an Intel Nuc I7 generation 10! ). Is Windows 7 the problem?

What version of HQPlayer?

1 Like

Deskop 4.17.2-82_AMD64 for Ubuntu

Is firewall off? Has it worked before? Win 7 is pretty old now.

1 Like

I asked because HQPlayer v3 was deprecated. Perhaps @jussi_laako might have an insight.

Moving this thread to the HQPlayer section.

1 Like

it worked before! What do you mean deprecated?

Does HQPlayer complain about missing internet connection on the status bar?

1 Like

No such message!

I have not seen such problem with the same HQPlayer package. So something is going wrong. You could check HQPlayer log file if there are error messages.

I assume the “allow network control” button is pressed in the toolbar. If you have iOS or Android device, you could check if HQPDcontrol can connect.

1 Like

When allow network is activated he gets the message: hqplayer may need an update

when allow network is deactivated he gets the message: no connection with Hqplayer

Have you checked from About-dialog that the HQPlayer version running is actually the latest and not something else? In case it has not been restarted after update or something.

1 Like

My friend has now checked and he is running the latest version!
He will go to Windows 10!

1 Like

Good idea ! Onwards and upwards !

He has now changed to Win 10 and gets the message ”no Audio Device”!

Are the dac drivers installed (ASIO from dac manufacturer or WASAPI)?
Is the dac connected, powered on and discovered by Windows?

So now Roon is on Windows 10 and HQPlayer on some other machine on Ubuntu?

1 Like

Yes! Its on an Intel Nuc gen 10!

OK, some things to check:

  1. HQPlayer has been added to Roon with correct IP address
  2. HQPlayer has been selected in Roon as output endpoint
  3. HQPlayer is running on the other computer and has “allow network control” enabled
  4. Firewall is not blocking connections to HQPlayer (shouldn’t happen on stock Ubuntu)
  5. HQPlayer has correct and functional output device selected

It is good to first check with standalone HQPlayer that you can play music, without Roon. And then try to play music from Roon once HQPlayer works standalone. This way it is easier to locate possible problems.


Thank you Jussi! We will check!

All points above OK! Where do you find Hqplayer log file?