Roon does not launch (hanging logo)

Hi @beka
I’ve just tried this reinstallation of the Roon server app and restored a backup. It didn’t work. I have a blank screen and a pulsating Roon icon and that is all. No music, no audio devices, nothing. My music is all still there but Roon can no longer see any of it. 1.8 Build 880 has completely wrecked my system and now I cannot play anything. If I could install build 850 again, that might work. Is that version of the app still available somewhere?

Hello again @beka
I’m not getting the “there was an issue loading your database” error. I just get this:

After a database restore, the core initialises and then shows ready, but connecting to it gives me that blank page and a pulsating Roon icon.


Hey @Alan_McMillan,

Thanks for clarifying :pray:

(I’ve made a brand new thread of your posts, so we can focus on your issue alone :nerd_face:)

Could you please share details about your setup as asked here?

Hi @beka
This is my system

Roon Core Machine

QNAP TS251 running firmware ver., QTS 4.3.4, Celeron processor and 8GB RAM

Networking Gear & Setup Details

Billion 7800 Router running through Netear 8 port unmanaged switch via ethernet

Connected Audio Devices

Meridian 218 Zone Controller

Number of Tracks in Library

Library of about 2500 albums

I deleted the Roon server app on my NAS and reinstalled it from scratch. My system is now rebuilding my library, again from scratch and it’s a mess because I had five years of curated details, covers, tags bookmarks, you name it and I appear to have lost the lot. I am NOT HAPPY! After the new library is built, I’m going to try restoring from one of my many backups because I frankly do not believe that my database could have been corrupted but nonetheless worked perfectly and it was this update that “uncovered” the corruption. I’m pretty sure something in this damned update did the corrupting and my library is now an organisational disaster thanks to it.

Hey @Alan_McMillan,

Thanks for all the details :pray:

Please, keep us posted on how that goes. I have my fingers crossed for a successful restored :crossed_fingers:

@beka I have the same problem, running Roon on my iMac with Mac OS 11.6.

What about uninstalling Roon and reinstalling? Why is Roon Support not suggesting we do that?

Can you point us to clear instructions for how to do that? Or is there some reason that’s not a good solution? I’ve been unable to listen to music for days.

Have you updated to Build 882?

That’s the most recent Build, right? Yes, I tried. Roon hasn’t worked for me since. I get nothing more than the “hanging logo.”

Yes, it was an update from 880 to 882 published yesterday. It seems to have solved a lot of problems for a lot of users.

1 Like

How does one update if Roon is in limbo as it is on my iMac?

I would suggest removing the software and reinstalling using the newest version.
That should help.

I just shut down my iMac and restarted, then restarted Roon. All of a sudden Build 882 was installed and my problem was solved.

I never chose to install Build 882. Others have told me Roon may have forced it to all of us. Whatever the explanation, I’m happy now because the problem is solved.

PS: I tried a restart yesterday and it did not accomplish this. So something changed.

1 Like

You can change that here:

I just shut down my iMac and restarted, then restarted Roon. All of a sudden Build 882 was installed and my problem was solved.

PS: I tried a restart yesterday and it did not accomplish this. So something changed.

You got updated from 880 to 882.

Roon update: I stopped Roon on the server, downloaded the latest build (882) and copied it to Applications (I am on a Mac) and restarted it. That did it. Roon started up normally and my pulsating logo was a thing of the past.


Not only did Build 882 give me my system back but the new update accessed and restored a backup from 25 days ago as that was the date stamp noted on the most recent albums added to the library. I got everything: tags, bookmarks, playlists, the lot. Everything is as it was before the disaster.
I would however like to ask someone how this squares with the “your database is irretrievably corrupted” story because when I tried under 880 to load every backup I have, I got nothing.


The only thing different in my case is I did not download Build 882. My Roon was updated automatically – or magically – when I restarted my iMac and reopened Roon today.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.