Roon does not load albums from Tidal

Core Machine (Operating system/System info/Roon build number)
Windows 10, Roon 1.8 built 778

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Moon680d, Moon600v2

Description Of Issue
I cannot not load albums from Tidal any more with Roon, though it’s now working with Mind2, a MooN680d application.

It’s all started yesterday. With Tidal not working on Roon, I’ve tried with Mind2. First, Mind2 responded that the Tidal server was not responding. Second, I closed Mind2, waited half an hour and, third, got back to Mind2. It worked. I’ve opened Roon, hoping the problem was solved. It wasn’t, and I cannot load any album from Tidal on Roon.

When trying to load an album from Tidal, the time bar shows a blue line going back and forth without stoping.

Roon Live Radio is working and I have access to my own albums located on the QNAP. And, I’m connected to Tidal Through Roon.


11 posts were split to a new topic: Trouble loading TIDAL content in Roon

Hi Francois,

I believe the @support works in the body of the text, not in the title.


I also have problems with Tidal in Roon could not login back to roon server, had to reinstall roon server to get back…I can only play tidal tracks that I have in my playlist but can’t search or browse Tidal… No answer from support yet…

What is your Roon server running on at the moment?

Same problem. I can’t browse or play anything that’s not already in my library. It’s been this way for the last couple of days I think. I’m running Roon Server on QNAP (
Version : 1.8 (build 778) stable
QPKG-Version : 2021-02-01

If I browse to Tidal I get this:

If I browse to a recommended album I get this: “Unexpected error loading album. Please try again later. (Unauthorized)”.

(Tidal) tracks and albums in my library work OK.

Roon 1.8 built 778 on Qnap

François Béland

If you go to search, search for an artist, choose an album (not in your library) and under versions, choose the Tidal version, does that play? Or is it just the Tidal page that has issues?

Example: I have a Tildal album in my library. It will not play. In the time bar, at screen botton, a blue line is going back and forth like crazy.

Hi Francois,

Not official support just a fellow user trying to be helpful. I would suggest as a test to use Roon loaded on the Windows PC as the core, (not adding any local music), just to see if you can play the Tidal albums on it out to just the basic System Output. In essence, testing to see if it is a general issue or QNAP specific.


As of this morning also Tidal titles which are not in my library can be played again. My issue resolved, how about others?

No my Tidal page is still showing empty playlists and albums…

Problem not solved. Still cannot play albums directly from TIDAL or TIDAL albums formerly downloaded in Tags.

Is there somebody from Roon listening?

Hi everyone @Francois_Beland,

Thanks so much for discussing this issue over the weekend - sorry we weren’t around.

I’m sorry that using TIDAL in Roon has proved to be difficult. While I can see that @Tamas_Szabo has already tried this, if you haven’t could you please:

  • Navigate to Settings → Services and log out of TIDAL
  • Reboot your Core (turn off, unplug for 30 seconds, turn back on)
  • Log back into TIDAL in Settings → Services

The next step would be to change the default DNS servers to Cloudflare DNS or Google DNS on your router.

Thanks in advance :pray:

1 Like

It’s now working, Thanks

1 Like

A post was split to a new topic: TIDAL loading continuously

2 posts were split to a new topic: TIDAL just spins and returns a network error

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.