Roon does not load tracks

Core Machine (Operating system/System info/Roon build number)

hello Roon Support, I have a lifetime license of Roon, currently version 1.7 (build 511), on a mid 2010 Apple Mac Mini running High Sierra OS version 10.13.6. This Mac has 8GB Ram and works perfectly.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

The music is 95% ripped from CDs and stored on an external 1TB HDD of Western Digital, the HDD is attached to the Mac via a Firewire cable.
the only wifi connection is between the Mac and the iPad

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

The Mac mini is connected to a Rega DAC R, via a USB cable, and thus to my hifi setup

Description Of Issue

Suddenly yesterday I started Roon to listen some music, but either on the iPad or directly on the Mac display, Roon stops playing back music, or it does not start at all, and gives me this error message: “Playback was interrupted because a track failed to load”.
If I wait and change album, it randomly plays the music, or not.
I used the old iTunes app on the Mac, and it plays regularly any album, any song.

Please help!

Hi @Valter_S,

Since experiencing this issue have you tried rebooting you Core machine?

If you play to System Output instead of the Rega is there any change?

HELLO there!
I tested my system with iTunes as a player for a full day, and it works.
Hence the failure in picking up tracks is only with Roon.
At first, tracks didnt even start. Now I noticed they would randomly start, but then they stop and the error message appears.
A second error message then pops in, saying that because of too many errors, playback is stopped (eg when playing randomly tracks within an album or a genre).

Any ideas? please help!
thx Valter

Hi @Valter_S,

As mentioned above, does the same behavior occur if you play to System Output instead of the Rega?

hello Dylan
yes even with changing the output from Rega back to System Output, Roon has the same behaviour. And also after several reboots.
I have tested that using exactly the same system with iTunes, all works perfectly

sorry this makes Roon completely unsable.
thanks for any help!

Thanks for confirming that it also happens with System Output, @Valter_S.

What is resource usage like on the Core machine during this time?

Is there any change if you disable any antivirus or firewall running on the machine?

hello Dylan
I do not have an AV on this machine. I will check this evening the FW configuration, and also the resource usage. PLS note that the Core Machine equals to the Mac Mini itself.

Hello Dylan, here is an update on your requests.

  1. enabling / disabling the firewall does not affect the functionality of Roon. It doesnt work. Besides, while being active, the firewall allows inbound traffic for installed/downloaded software, and Roon in particular has a dedicated rule for allowing inbound connections.

  2. when you speak of resource usage, I understand I need to check in the activity monitor of my Mac Mini.
    If so, the CPU usage while Roon boots is quite high, up to 70%, but once completely loaded, it stabilizes around 10 to 15% in idle mode.
    While in use, regular CPU usage sits around 20-25%. But I have noticed, when Roon stops working with the error message that one or more tracks failed to load, then CPU usage peaks around 45-49%.
    Pls Help

hi there! No response so far??!

Hi @Valter_S,

Please accept my sincere apologies for the delay here! Your previous response slipped by me and for that I am sorry.

So far we’ve determined that:

  • Firewall / AV does not affect things here
  • Playing to system output on the Core machine also exhibits this issue
  • Rebooting the Core machine results in no change
  • CPU usage is not abnormally high

Moving forward, I’d like to suggest this:

  • Move an album to an internal drive on the Mac Mini instead of the external drive
  • Add that location as a watched folder in Settings > Storage
  • Try to play this content from the internal drive

Does the same behavior occur?

Hello Dylan
ok thanks I’ll follow your advice, but not earlier than next thursday, as I am off for biz trips.
we’ll catch up next friday 31st,

1 Like

Hello Dylan

I tried with multiple albums in 2 different tries… behaviour is the same. Roon stops playing with the same error message than before.

Also, pls let me remind that with iTunes, play goes fine in all cases: song shuffle, album sequential, genre shuffle… so it cannot be a HDD problem.
Again, please help

Hello Dylan, Roon Support!

some time has passed and I still don’t see an answer. Moreover, the problem continues and I cannot use Roon, for which I paid 120 bucks for 1 year usage, + 430 USD for lifetime license!!!

Is Roon support so poor!!!
Should I ask my money back??!!!

Please accept our sincere apologies for the delay here, @Valter_S!

Our team has been hard at work on the latest Roon release which came out a few days ago — Have you tried this update? Are you still experiencing the issue on this version?

If so, I’d like to escalate this to our senior development team during our meeting this week. To do this, I’m hoping you can once more reproduce the issue and make a note of the time it occurs and the track you try to play – I’ll enable diagnostics once more so we can review on the latest version and will bring it to the team during our meeting.


hello Dylan,
thanks for your reply.
I am off the entire next week for business travel, I’ll get back on sunday March 8th, and on Monday 9th I’ll test my system again with the new sw release and get back to you.

Hello Dylan
problem resolved with upgrade to Roon 1.7 (build 537). thanks

this case can be closed

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.