Roon does not properly handle mDNS source address from Airplay devices

Continuing the discussion from Remote control from another LAN:


As I mentioned in the linked topic, I did some experiments with airplay on my receiver and Roon.

The setup is Roon Core running on a computer (iMac) within its own VLAN, and the rest of my home network in another VLAN. Both VLANs are connected to a ubiquity router without any firewalling/NATTing between them

I configured the router to work as an MDNS reflector (ships mDNS packets form one VLAN to the other, in both directions), which made Roon discover my airplay server. However, I could not actually play any music on it. I conjectured that was due to Roon using the address of the node sending the MDNS packet reaching Roon Core (which in this setup is the router).

Well I think I confirmed this is the case. I just realised in the Roon interface for Audio config, the IP Roon thinks the Airplay server has is printed in grey beneath the friendly name of the server. Effectively, Roon thinks the airplay server sits at the router.

I checked with an mDNS inspector that the correct source IP address of the server is included in the mDNS packet. Thus, what must be happening is that Roon ignores that information and only pays attention to the IP of the node sending the mDNS packet: the router in my case.

I belive this is incorrect behaviour that should be fixed. Doing so will enable scenarios for airplay devices in which a home network runs on various vlans.

Could this also cause my airplay problem?

Hi @AE67,

I have not tried using the remote in my receiver to control the playlist, at least not yet. I will try that later and see what happens (I will need to put my iMac in the same VLAN as my receiver to even try it).

I have to say I am no expert on Airplay or its implementations. I just brushed up lately to understand what may be wrong with the setup I had.

However, from my findings wrt mDNS, it may be possible that Roon handling of Airplay is incomplete. I read through the discussion you started, and it seems you have all your devices on the same VLAN, so I would say it is unlikely that the exact same issue I found is affecting you.


I tried to control the playlist from my Pioneer receiver under airplay and it does not work. Actually it interrupts playing and need to resort to the Roon remote to continue listening through it.

Ok, thanks for checking.
So, you have the same behaviour as I have.
The strange thing is, that it works in the past and I started with Roon 1.2, never used an older version. So for me it can’t be new with Roon 1.2.