Roon does not recognize my NAS location [Resolved]

I’m new to roon and trying to set it up to read from my synology NAS. I have just download the latest version onto my MacBook Pro and trying to add the folder location of my NAS using the smb file path. When I click on the Add Network Share button I get an error box saying unexpected error: Invalid Network Path.

The path was copied from what is listed in the file services under control panel. Can anyone help figure out if I am doing something incorrect or is the software the issue?

@Thomas_Fernandez Can you tell us what you typed in as your path?


Mine looks like


and its case sensitive so make sure its as per the share name in the NAS - I’m using DSM 6.1 on a Synology so this should work for you with the right IP address in there of course.

See also’s_the_best_way_to_configure_my_NAS_for_Roon%3F

@wizardofoz The path you typed is not what shows in the post? The \\ shows as ’


Corrected as I was typing.

The path I typed was smb://TF_iTunes

@Tdogzthmn Try \\\TF_iTunes and add any passwords it gives you the option to enter even if you don’t think you need them and see how it goes.

Tried the path you suggested with my NAS username and pass. I ended up with an UnexpectedError message. It does seem like it’s trying to connect and I can hear activity on the NAS.

I also used the IP address listed for my NAS and got a message saying Unauthorized

I got it to work!

Had to change the IP address I used and the folder name, but I got it to recognize the folder location for my remote iTunes Library.

Certainly not an easy setup for someone with limited computer knowledge. Hope they can improve this in the future!

Glad you got it working…I was going to pop in with a use your IP address not ratberts, but I see you figured that out and your music folder name I guess was perhaps not as you had thought.

Moved to the support folder and subject [Resolved] added

Oops! Sorry for the confusion, I should have added ‘insert your ip address’ :blush:


That isn’t my ipaddress anyway…