Roon does not see Apple TV's

I have 2 Apple TV’s set up on my network, but they do not appear in Roon. One Apple TV is connected by ethernet, the other wirelessly.

How do I get Roon to see them?

(I tried to upload screenshots of Roon preferences and iTunes showing both Apple TV’s, but got error messages multiple times.)

Hey Now,

I just downloaded Roon last night and it found my Apple TV wirelessly okay. Haven’t tried to play anything over it, still trying to get music out via USB.

Kind of buggy if you ask me. 8^) Good luck.

Finest kind,

Hey @SVinTO – take a look at the instructions posted here and let me know if you’re still having issues ok?

And @ccklone if you’re having any problems, let us know.

Thanks guys!

Hey Now Mike,

Yes, I am having problems. I have made a couple of posts already. Can’t get Roon to play via USB to 3 of my USB DACs. Keep getting:

TRANSPORT: Playback has failed due to playback parameter negotiation with the audio device.

If you can provide some assistance it would be much appreciated. Thanks.

Finest kind,

The Apple TV already has Device Verification set to OFF. But it does not show up in Roon.

Hey @SVinTO, sorry if this is a stupid question, but did you enable your Apple TV’s in Settings > Devices?

Cheers, Greg

Which settings do you mean? Apple TV Settings, OS X system preferences or Roon’s preferences?


Sorry, I mean in Roon settings.


That’s the problem. Neither Apple TV appears in Roon’s settings to be enabled. Though they both appear in iTunes.

Are Roon and Apple TV on the same network? i had a guest network in the past and it caused some problems.

That’s all I got.


Roon and Apple TVs are on the same network. As posted, one is connected by ethernet directly to the same router as the computer running Roon. The other Apple TV is connected to the same network wirelessly.

Hi @SVinTO – can you confirm what generation of AppleTV you’re having this issue with, and what version of firmware both units are running?

Also, can you let us know the information about your Roon setup and network, as described here?

We’ve had very few issues with AppleTVs, so I’m sure we can figure out what’s going on here. Thanks and sorry for the trouble!

[quote=“mike, post:12, topic:2996”]
Hi @SVinTO – can you confirm what generation of AppleTV you’re having this issue with, and what version of firmware both units are running?[/quote]

  1. Apple TV 3 model A1427 running Apple TV software 7.2 (7512) connected by ethernet cable to switch that is connected by cable to Apple router.

  2. Apple TV 2 model FC572LL/A running Apple TV software 6.2.1 (6698.99.50.41) connected wirelessly to same Apple router

Roon Version 1.0 build 30 (stable)
OS X Yosemite 10.10.4
iMac 3.06 GHz Intel Core 2 Duo 12 Gig RAM
Music stored on Iomega external HD connected by Firewire

Hope that helps.

See attached screenshots of Roon settings showing no Apple TV’s but OS X System Preferences showing Apple TV’s.

OK, thanks @SVinTO – I just sent you a PM about getting some logs and more information from your install. We’d like to take a deeper look here, then I’m sure we can figure out what’s happening.

Take a look and I’ll talk to you soon. Thanks and sorry for the trouble!

Was there a resolution to this issue? I seem to be having a similar problem.

Not resolved for me yet.

My 3 Apple TVs were available and worked well following my installation of Roon.

I had an issue when they disappeared from Roon but still showed up in Airplay and iTunes. I navigated the Apple TV settings menu to Restart and selected it. Voila! The Apple TVs again appeared.

That was my fix, restarting the Apple TVs. I think they disappeared from Roon after I restarted my router during a ISP throughput slowdown investigation/troubleshoot.


@pwright92 – can you tell us a little more about your setup and network (as described here), as well as the details of your Apple TVs (model and firmware version would be great).

We’ve been doing some investigation on this issue, but haven’t been able to reproduce it in house – most people see these Airplay devices consistently without issue, while a handful of people have needed to wait for the device to show up or, in the worst cases, have been unable to locate the devices at all.

We’re working to identify the cause of these issues, so the more details you can provide the better – anything on your laptop that might be related to networking (firewall, VPN, etc) would be great to know, as would anything related to Airplay on your network. We discovered a bug a while back that was only triggered if Roon was talking to an Airplay device while iTunes was also open, which of course slipped by because none of us use iTunes regularly :grin:

Anyway, let me know the details and we’ll figure out what’s going on here. Thanks!

A reminder that I only saw Apple TV’s once in 6 months of use. While renaming Library/Roon and reinstalling Roon did resolve my start up issue, I have not been able to see Apple TV’s despite restarting them as user suggested.