Roon does not see Mytek Brooklyn DAC

Roon doesn’t seem to be able to find my Mytek Brooklyn DAC.

Is it the original Brooklyn? Is the connection through USB? What is the hardware connected to the Mytek?

Thanks for sharing your report with us, @Patrick_O_Brien!

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Was Roon previously able to see this DAC? Are other endpoints seen?

Have you tried rebooting the DAC and your Core machine?


All is well. The startup routine had me baffled but I prevailed in the end. Thanks for trying…

I spoke too soon.

I still get a message when I start up that no device has been found.

If I go to settings > Audio > Networked it says “no device located” when I have a Mytek Brooklyn DAC that works with TIDAL without any issues.

Same problem yesterday then after messing with everything I could think of the Room suddenly recognized the DAC an all worked fine.

Why doesn’t it recognize it wh I turn Roon on?

Hello @Patrick_O_Brien,

Thanks for contacting support. Can you please provide a description of your setup using this link as a guide? Please let us know the make/model of any networking gear you have and how your Mytek is connected in the setup (Ethernet or WiFi). More information regarding your Core and what Operating System and Roon Version it’s running would be helpful as well.

Do you have any other Networked DACs that are failing to show up or is it only the Brooklyn? Have you rebooted your Core and Mytek? Do you by any chance have a firewall active that could possibly be blocking Roon from discovering the Mytek? Please let me know your replies when possible.


I have a Mac Mini with Ethernet connection to the Brooklyn and it right now works perfectly with Tidal so there’s no firewall that wasn’t there yesterday when I was using Roon

Hello @Patrick_O_Brien,

Just to confirm the Mytek is working as expected now? How often does the issue of it not working happen? Can you please provide the make/model of your Router if the issue occurs again? You may want to try restarting your Router and computer in case you haven’t done so already.


It is right now working normally with Tidal but won’t recognize and device while in Roon.

The router is working perfectly when I use Tidal without Roon. When I use Roon it gives the message “no devices found”

This cannot be the only time someone has had this problem

Hello @Patrick_O_Brien,

Thanks for clarifying that for me. Can you please let me know the model and manufacturer of your router? Have you tried rebooting your computer and your router as I previously suggested and it is still not showing up? Can you try another USB cable for the Mytek connection to the PC? We need to narrow down the possible causes one by one and this information will be very useful in providing you accurate next steps forward here.


I rebooted everything. Now it’s working.

Thanks, hope I don’t have to do this every time

Hello @Patrick_O_Brien,

Glad to hear that rebooting everything has resolved the issue (at least for now). If this occurs again please let us know your Router make/model because I suspect the issue was due to network connectivity and rebooting the Core and the network provided a “fresh” state which allowed Roon to properly locate your Mytek DAC.


Earlier today I started up roon and it found no audio devices. I shut roon Down and restarted and it worked.
Later I started it up again and got the same message and haven’t been able to make it work

The router has given me no trouble in the past and Tidal works without incident

Hello @Patrick_O_Brien,

I understand that TIDAL has worked in the past without incident but Roon uses a different way of communication when it is talking to your devices. We use RAAT to communicate with the devices and for proper communication to happen a stable network connection is required, sometimes routers need to be tweaked a bit for the best performance and knowing the router manufacturer/router will help us assist you better.

Another couple of possible things to check is replacing the USB cable connecting to the DAC and the firmware version on the Mytek DAC, I am not sure if you have updated it to the newest version but it could be worth a check to see if it is updated since that could be another reason why it only sometimes connects. The link to drivers and firmware can be found on Mytek’s site here:

I hope this information is useful and if you have any new findings or questions just let me know.


The router is Xfinity dual band WiFi 802.11ac XB3

The DAC came straight from Mytek a couple weeks ago. Firmware 2.36 rev 0654

Hello @Patrick_O_Brien,

We have had a few users report that without their knowledge MacOS has forgotten their firewall settings for Roon. I would recommend as a first step disabling your MacOS firewall and seeing if the behavior you are seeing in regards to Roon not discovering audio devices changes. You will be protected by the firewall on the XFinity router from outside threats, so there is little to no risk in doing this. Please make sure to reboot the Mac after making this change to make sure that the settings were applied.

If the issue you are seeing persists even after disabling the firewall, we will need to take a look at your Roon logs to get a better idea of what is happening. If you could use the directions found here and send us over a set of logs using a shared Dropbox link, we’d be happy to take a look!


The firewall has always been turned off

Is this really worth the trouble?

Sending logs is always worth the trouble - how else can someone help you? The Roon people do magic, but I don’t think they solve problems by meditation/“seeing things” or just put their hand on their own monitor :slight_smile: