Roon does not stop detecting tracks

Normally, whenever I want to import a new album, I force a scan. The album is soon imported and after a little while Roon stops detecting tracks (flashing circle, top right).
Recently, however, I tried to import a 6ch album that I can play 2ch stereo with HQPlayer.
The album is:
Andris Nelsons, BSO - Wagner Overture Tannhauser , Sibelius Symph 2 (2014, 24-96)

Roon was NOT able to import and from that moment on the flashing circle never stopped working.
After a couple of days I converted the above album to 2ch stereo and removed the multi-channel version from my NAS.
Roon imported the album immediately. However, the flashing circle is still working.
I do not know if this is due to my original attempt to import the multi-channel album, but it seems as if the album is still in a temporary database and Roon tries to detect it and ends up in a loop.

I stop/start the server, but Roon is stuck working, trying to import files. It is obviously rather annoying.

Is there anything I can do?
Is there a way to reset Roon “internal history”?

Run database cleanup in settings. See if that helps.

Thanks for your reply.
Unfortunately, it didn’t. :disappointed:
Roon continues to be “active”.

If you click on the spinning circle, a dialogue box appears.
Can you screen shot and paste that in here ?

Can press on the spinning circle press take a screenshot of the appeared pop-up and paste it here, thanks.

I have a similar problem. My spinner has been going non-stop since 1.2. I sent the details to the team but there has been no further communication about it, so I guess there is no solution.

I also have multichannel files which are mentioned in the logs, but I was told that was not the problem.

Here is the screenshot:

Hi @bibo01 ----- Thank you for your feedback and I apologize for the inconvenience. While I try to narrow down what could be going on here, I wanted to ask you very quickly if rebooting your “core” machine has yielded any different results, in regard to the issue(s) being highlighted above. Your input is greatly valued, thanks!

  • Eric

I had tried to reboot my core machine with no difference before.
I just tried again now, but I still get the same system behavior and, if I click on the spinning circle, the same message.

I do not know if it has a direct relevance, but adding a new album with 14 tracks has elevated the bottom count to 297:

Does that “0 Identified” mean that something has happened (possibly trying to add a multi-ch album) and from that moment on Roon cannot identifiy the metadata and retrieve extra material??

EDIT: indeed, all the more recent acquired albums have no artist’s biography, etc… This IS a bother if it cannot be fixed!

Question -
When an update to Roon Core is available, will it stop this problem? Kind of reset the database?
Otherwise I keep accumulating new albums that do NOT have info and no cross referencing.

It looks like you are no communicating with the web database. Anything showing in your firewall settings ?

@Eric, you might be able to advise ?

Firewall settings?!
I doubt it - I haven’t touched or updated my Linux server in weeks.
As reported, that multi-channel album has triggered a “hiccup” in Roon and now all new albums are simply put in the database. Before it was fine.
Would it be a good idea to try reinstalling Roon Server?

No :slight_smile: Would you mind to share Roon logs with us ? I’ll contact you via PM with more details.