Roon Doesn’t See Blusound Devices

Basic Problem: The Roon App does not see the BluSound Pulses and Node (connected to my AV receiver by HDMI). I am converting my Roon core from one that resided on my MacMini to one that resides on the Nucleus.

Initial Setup: The BlueSound Pulse and Nodes were visible in the App when the Core was the MacMini. Until I bought the Nighthawk router (see below), all the connections were the same in terms of my network and where my NAS server (WDMyCloudMirror) was located. All I did was plug the Nucleus into the Cable Company cable-modem (Comcast xfi). I also installed a backup of my database to the Nucleus using a USB stick. Even though I was using the same path that I used when originally adding the NAS server to the Mac, the Roon App did not see the Nas server. I let that go, ordered an internal hard drive (arrives on Tuesday), and just used Tidal for testing. I also put some music files on Passport USB drive, and the Nucleus saw those when I plugged the Passport into the Nucleus USB slot.

This past weekend, I bought a Nighthawk AX5 router because a community post said that Blusound may have trouble with cable company cable modems. I have the router now working in Bridge Mode. I still do not see the BluSound devices in Roon–two Pulses and one node. So the router made no difference.

Detailed Current Setup: Here is the current setup:

The Nucleus is connected to the Nighthawk router by ethernet cable. I have expanded my Wifi network with the Eeco mesh system. I have 6 Eeco devices hooked up. Several contain ethernet inputs.

If I use ethernet to connect a Pulse directly to the Nighthawk, the BluSound Pulse shows up in the Roon app. If I do not connect it, relying just on WIFI, the Pulse does not show up in the Roon app. And if I connect the Blusound Pulse to one of the Eeco’s with an ethernet connection, the Blusound Pulse does not show up in the Roon App. Same is true for the Node. It has always been connected to an Eeco using ethernet. It currently does not work.

I took a look at your network best practices guide. It brought me back to the days when you put a record a turntable that was connected to a stereo system. I heard music without having to be an electrical engineer.

Let’s start with iPv6, which Roon says to avoid. I checked, and it is not on the Eeco network. The Nighthawk is not transparent, so I don’t know whether it is on iPv6. As I understand it, iPv6 is a new internet protocol for addresses. I find it a bit troublesome that I need to turn off what is new rather than you and Blusound issuing software updates to make the system work with the new protocol.

Subnets. It appears that all devices have one of two subnets: and I have no idea how to change this if it is a problem. I do note that the apps for the Nighthawk and Eero show lots of devices–about 20–but that most are shown as unconnected, which is strange because our AppleTV, SmartTV, HomeTheatre Receiver, all iPads, and all computers are currently connected to the internet and working. Bluesound shows two of the three devices. For all these devices, I did a factory reset before connecting. I will say it took a long time for the BluSound App to recognize the devices–like 15 minutes, and in once case, that was with the Node sitting 20 feet from the Nighthawk in the same room.

Wifi Extenders. The fact that I am using a mesh system seems to be the right choice.

Miconfigured Web Access Points. The Router is forcing me to use something–SmartConnect–it decides whether to at 2.4 or 5 based on what will work best for each device on the network. I have set the Access Point on the Nighthawk to WPA3. I have also tried WPA2. Doesn’t to seem to make a difference. Once again, I am a bit confused because I don’t see anything on the BluSound app that would allow me to change an access point.

Poor Quality Routers. In reviewing the signal strength for various devices, it always comes back very strong.

Wifi Interference. We have a microwave/convection oven. We run it for 10 minutes a day–heat food. That doesn’t seem to have any impact.

Btw, after 20 or so hours of hacking away at this, I have done the obvious things, including factory resets, reconnecting to network, reinstalling the Core, checking that the power is on, etc.

Thanks for any guidance.

You have two networks set up.
Unplug the nighthawk as a first step and see if everything sees everything else then.

I will try that, but I don’t think that is the problem. Before I added the Nighthawk, I had the exact same problem using the Comcast Xfinity modem/router. Roon didn’t see the Blusound devices, and there was clearly only one network. When I reverted to my old core on my Mac, using the unabridged original network from the Comcast modem-router, Roon saw the Blusound devices. So the swap of the hardware (Mac to Nucleus) or the creation of a new core appears to be the source of the problem.

Go back to one network. Get the bluesound issue sorted then introduce a new network device. You have too many variables changing for anyone to troubleshoot as it stands now.
Having two subnet masks in play (255 etc) is odd and should not be the case.

Actually I don’t have too many issues. I solved the pathway to the NAS Server. I will put the hard drive in once the BluSound is fixed. I will also address CD transfers and backups of the music files after Blusound is fixed. I am only working on Blusound, and the bridged router configuration was done after reading a post in the Community that indicated that bridging was a potential solution for the BluSound issue.

Thank you.

I agree with Ged, there are too many variables in play. Where are your Eero mesh devices plugged into? I believe you need the cable modem connected into the Nighthawk WAN port, and then the Eero mesh master device plugged into a LAN port on the Nighthawk. The Nighthawk probably needs to be in router mode and the Eero mesh in bridge or access point mode.

Xfinity Cable Modem->Nighthawk in Router mode->Master Eero mesh access point, with all “->” being Ethernet cable connections.

I haven’t used Eero devices, but have set up a number of ASUS Aimesh and Linksys Velop mesh networks for friends and family over the past three months. It seems you have too many competing networks in play here. I’m not sure the Eero devices will play well with a Nighthawk router since they are both acting as full-service routers.

1 Like

Correction: EECO got in my head. It is Eero. Apologies.

Jack B. Siegel