Roon doesn’t sync Tidal albums

Core Machine (Operating system/System/Roon build number)

Nucleus, V1, build 227

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Eero network

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Issue with library

Description Of Issue

. For months now Tidal and Roon libraries don’t sync. I have been waiting for it to sort itself out but it doesn’t seem to be happening. Super annoying.

Do you have any advice?

kris k
I have the same problem as you do (tidal not syncing to roon). Everything worked fine in the past but, all of a sudden, the syncing quit and I can’t pull up albums from tidal when I do an artist search in roon.
Did you ever find a solution?

Hi @Kris_K,

Can you go to Settings > Services, click Edit next to TIDAL, and share a screenshot showing the last sync time?

Thanks!

Hi, here you go. I do not recall having seen a date there ever.

Hi, I can pull up the artists. But the sync is not happening a lot of the time.

Hi @Kris_K,

Can you please share a screenshot of your Nucleus Web UI?

Of course, please let me know if more is needed.

1 Like

Hi @Kris_K,

Thanks for that screenshot. You don’t appear to be using a valid DNS server, I would advise you change this to DNS to Cloudflare DNS, Quad9 or Google DNS or set DHCP instead and ROCK can get the DNS settings from the router.

1 Like

I have changed to the below. How long should I wait to confirm that it is working. (Not yet though)

Hi @Kris_K,

That is a very strange DNS server, can you try to access the Eero network and see if you can change the DNS on the router to Cloudflare DNS, Quad9 or Google DNS?

Hi, I changed to Google. Any other steps you recommend?

The list is not synced between Tidal and Roon for now.

1 Like

Just to clarify, when you say the libraries are not syncing, do you mean that when

  1. you favorite an album in Tidal and it does not show up in Roon’s library, or,
  2. you add an album in Roon to your library and it is not then a favorite in Tidal, or,
  3. Generally, your Favorites in Tidal do not match your Tidal Albums in Roon’s library.

In your screen shot at the beginning, Roon’s library is in Date Added Sort. How are you sorting the Tidal app?

Also, I noticed you have a VPN going. If that is on the same network as the Roon core, try turning that off and see if Tidal syncs.

Mostly it is #1 as far as I can remember. I add or remove in Tidal and it doesn’t get consistently reflected in Roon.

I also sort on date added in Tidal. The VPN is only on my phone where I took screenshots, Tidal albums list looks the same on my iPad. Doesn’t play a role that I have VPN on the phone.

1 Like

Hi @Kris_K,

Thanks for getting the DNS sorted out, it’s looking better. Can you please check the status of your TIDAL sync under Roon Settings -> Services?

Does Roon say that the sync completed or that it is still syncing? If it is still syncing, please try to logout and back into TIDAL via Roon.

@noris I did last night, logged out and in, in Roon, no VPN, and it is still the same, still syncing.

Hi @Kris_K,

Thanks for checking that aspect. For next steps, can I please ask that you access your Nucleus Roon logs by using these instructions and send me a set? Any issues accessing logs, just let me know and I can clarify, thanks!

@noris, thank you. I have sent you a link.

Hi @Kris_K,

Thank you again for sending those logs over and for your patience here while we’ve had a chance to look into your case further!

According to the logs, it doesn’t seem like the Nucleus is able to make any external network connections, all of the networks requests are failing, so to me this looks like a networking issue.

I have a few suggestions as how to proceed with troubleshooting, which I’ve noted below:

  1. I would start off by rebooting both the Nucleus (via the Web Interface) and your router

  2. Check to make sure you have the latest router firmware installed

  3. How is the Nucleus connected to the Eero network, is it going direct into the router or through a satellite/switch? If you are using one of the satellites/switches, please try to connect to the primary router.

  4. Create a Backup of your Roon Database and perform a Nucleus OS reinstall:

Please let me know if any of the above suggestions help with the issue, thanks!

1 Like