Roon doesn't always see KEF LS50 Wireless

I have Roon core on a MS Surface Pro 4 (i7, 64bit, 8Gb, Win10 but a few years old) and use as a remote a Samsung Galaxy Note 2 tablet, and Tidal and KEF LS50 wireless.

I use a wifi connection. But often Roon doesn’t see the KEF speakers, neither on the Surface nor on the tablet. Why not?

On the tablet I start the KEF app - by pressing the wifi button - but Roon doesn’t list the speakers. But on the KEF streaming app, the KEF speakers are listed and I can play music from that app’s Tidal section just fine.

I wait a while and Roon still doesn’t see the speakers. I think the workaround that works best is to restart Roon on the Surface.

Any clue to make this minor annoyance disappear? Thanks,

Maybe it’s worth trying to start Roon after the Kef’s are connected TU o wifi. Then turn on Roon?

Hi @Bernard_Rene,

What is your network setup like? We’ve previously seen a few routers that need special settings to be applied for them to function properly with Roon, they are documented at the end of our Networking Best Practices Guide. Also, if you temporarily try connecting the LS50s via Ethernet, does the issue go away? That will give us another good data point.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.