Roon doesn't find Dragonfly Red on one of my desktops

I have just bought a Dragonfly Red. It is detected by Roon on my older desktop (running Win10 Pro x64) and works there. On my newer desktop (ASUS GD30CI, running the same version of Windows), Roon doesn’t find the Dragonfly (see below); in fact, on that desktop, Roon now doesn’t detect any potential endpoints (locally attached, that is); it used to.

(The Dragonfly works fine on this newer desktop outside Roon; eg, I can go to web sites like Presto Classical to play music samples.)


@James_Antognini ---- Thanks for the feedback!

Does the new Asus GD30CI (i.e “newer desktop”) have any firewalls or antivirus applications currently enabled? If it does kindly disable these functions temporarily and confirm if this action yields a change in behavior with the mentioned dragonfly red.


In Windows Defender Firewall, I turned it off for Public Network, and Roon detected the Dragonfly (and 3 other devices on the local machine). I then played successfully on the IDed (now a zone) Dragonfly. When I switched the Public Network firewall back on, the Dragonfly stopped, and the display of local endpoints disappeared.

Looking at Windows Defender Firewall, I see several Roon-related things are blocked. Which should I unblock?

(On the older desktop, where Dragonfly is usable by Roon, RaatServer.exe and Roon.exe are unblocked. I don’t recall ever touch these Roon-related settings on either desktop.)

The reports were all for inbound requests, so I felt that activity wasn’t too worrying. I unblocked (allowed) the pertinent rules, and things now work with Dragonfly.

1 Like

Thanks for touching base with me @James_Antognini and my apologies for the delay on my end.

Very pleased to hear the mentioned adjustments have yielded a positive change in behavior here. For reference, you want to make sure that there are security exceptions in place for both “Roon” and “RAATServer”.

Happy listening!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.