Roon doesn't recognize perfectwave dac bridge II after 2 years

**Core Machine

HP laptop i5 Windows 10 Roon 1.7 Build 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Actiontec (Telus) Modem/Router T3200M - connected via Ethernet to Perfectwave DAC Bridge II. Synology DS214Play NAS also connected through Ethernet to Modem. Laptop connected through wifi running Roon Core.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PS Audio Perfectwave DAC 2 with Bridge II

Description Of Issue

about 6 days ago Roon doesn’t detect my BridgeII/DAC anymore. Everything has worked flawlessly for at least 2 years. My bridge has the latest firmwarm and says ‘network connected’. I have cycled power on the modem, DAC and laptop numerous times with no success. Please help! So frustrating to have no music! I don’t use anything else as an endpoint. Roon however does see other devices on the network such as my two kids’ Google Minis, and my Sony Bravia TV.


OK - I feel a little silly. I decided to hook my laptop up through ethernet and now Roon recognizes the BridgeII. Why all of sudden though can it not recognize it through wifi?

Hello @Terence_Tam, we sometimes see issue like these when the core isn’t connected to Ethernet. Our networking best practices also recommends this to avoid these kind of issues.

Thanks for the response. It still seems strange to me that it was doing fine using wireless and then one day I need to be hardwired.

Nevertheless I decided to use a different laptop (i5 - 4th gen, 8GB Ram, SSD drive) to be the core and my original laptop to use as a controller. Core works fine. However the control/remote laptop connects to the core on booting up (but always asks to connect). It will work for a variable length of time - minutes to hours - and then loose connection. ‘Remote connection lost’. When I try to reconnect I have to instruct Roon to look for a new core. It the detects the core but cycles between ‘attempting connection’ and 'failed connection. I’ve tried getting turning off firewalls on both computers with no help. However, hardwiring the remote laptop did fix the problem. So somehow it is a networking problem…but I have no idea how to fix this. Same problem from trying to use an Android tablet or iphone as remote - won’t connect to core…would appreciate some help!


Hi @Terence_Tam,

Besides the Actiontec router do you have any other networking devices in use (switches, wireless access points, etc.)?

Is the Core going into a sleep mode during this time, or is Roon up and running without problems on the Core?

Yes I’m using a D-Link DGS 1005G Gigabit 5 port switch. The laptop is set to never sleep. Seems to be no problems running Roon on the Core (although it’s been only about a week with the new laptop Core. The IP address matches up (the remote is looking for the correct IP address).

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.