Roon doesn't update any metadata

I can’t find my specific problem listed anywhere in the forum. So, here goes. I just installed Roon Rock on the recommended config NUC7I7BH 8G RAM and 128G SSD. All seemed to go in very smoothly. Connection to my QNAP NAS went smoothly. Tidal connectivity is fine. Roon plays audio track from both NAS and Tidal just fine through my output device.

Roon Server Version 1.3 (build 276)
OS Version 1.0 (build 150)

My problem is that ROON isn’t collecting any metadata, album art, etc. I’ve been trying things for 2 nights. What am I missing? What can I try?

As Roon indicates, nothing imported has been identified, which is key to making connections with artwork, metadata, etc.


Thanks, Andrew. I really appreciate any help I can get. So, why is nothing getting identified? It’s like the Roon Server can’t connect/see the internet? Should that little circle in the picture just keep spinning and spinning?

Hi Matt,

Support will be along soon to check logs. Do you have any firewalls that might be preventing Roon from communicating over the Internet ?

Thanks, Andrew. I tried turning off the firewall and IPv6 firewall on the router. That didn’t seem to make a difference.

@andybob or @support
Any other ideas? Is there something I can I check in the NUC that would indicate whether or not my ROON database has data in it… or that it is able to see the internet?

Thanks 1,000,000

Hey @Matt_Oess – this is almost always because something about your network is making Roon unable to talk to our servers.

Can you let us know the topology of your network and how everything is connected? I’ve also enabled some diagnostics on your account, so we can pull a report and have a look at your logs.

Once @support has a description of your network and that report, I’m sure we can figure this out. Thanks!


In the mean time you could give this a try, from an iPad or other remote device try going into Settings then Library then set background analysis speed to off and confirm it, then set background analysis to maximum and confirm it, I have had the analysis hang and doing this resolved the issue for me and hopefully for you too?

Thanks @mike and @support
I have a netgear DSL modem, connected to my ASUS RT-AC3100 wireless router, connected to my Netgear JGS516PE - 16-Port Gigabit ProSAFE Plus Switch.
Currently, I have the ROCK/NUC7i7BNH connected directly to the ASUS router, but have tried it connected to the GigE Switch. My QNAP NAS TS-251+ is also connected to the GigE Switch (houses my ~400 music files).

I’m really grateful for the help on Saturday. Can I send you/upload logs or anything?

@Ratbert, Thanks for the suggestion. I did see that suggestion on another post and tried it. I tried it again just now. No joy yet.

@Matt_Oess Ok, sorry it didn’t help, I have the same router and NUC as you and all works so I am sure this can be resolved, is there any firewall sw running on the qnap? I have my music on usb drives connected directly to my NUC, as a test can you plug in a drive or memory stick on the NUC with some albums on and add it in as storage and see if metadata is retrieved?

Thanks again for jumping in. I couldn’t find anything in the QNAP that looked like a firewall, and definitely haven’t added a QNAP firewall app.

I did try your suggestion with the USB stick, directly into the ROCK. The music is imported fine, but it still doesn’t appear to pull any data. Just to make sure I’m not missing something, what would I see that would tell me that metadata is now there or not there? If I see “2087 tracks, 2087 added, 0 identified”, the # identified should be >0, right?


Hey Matt,

I’ve enabled some diagnostics and forwarded the info on to our developers.

In the mean time, my general recommendation for these symptoms would be simplifying the network as much as possible. Based on what you’re describing, things are reasonably simple already, but you might try taking that switch out of the network temporarily, just to verify it’s not causing any issues.

Is everything running DHCP? Or have you assigned static addresses?

Thanks @mike. I’m grateful for the help. Good thought.

I took the switch out of the chain. Only thing connected to the router’s ethernet port is the NUC. No love.

I am running DHCP. I have static IPs for the GigE switch, ROCK, and the NAS server. That’s it.

Does your ROCK server have a valid DNS entry? Can you share a screendump of ROCK’s setup/status screen?

My router is
The DSL modem is

Could this be an issue with ports being blocked on the router? Not sure what ports Rock requires, I am sure someone will post the answer.

This is a long shot, as I doubt that Roon identification would continue churning fruitlessly without giving up, but is any/all of your library not up to Roon folder organization and metadata standards for automatic identification?


It just so happens that I bought a new router. I bought the ORBI from Netgear. (it’s really awesome BTW).

Anyway, how likely could it be that both routers (my old ASUS and the new Orbi) are both blocking?

Hopefully @support will jump on it.

Thanks again, @WiWavelength.

It seems that either the Tidal tracks or those on the NAS would be identified… I have “0 identified”. Right?