Roon dosn't work (no GUI) [Solved]

Core Machine
HP Envy 360x pretty new, Intel i7 (11th Gen), Grafic card Intel Iris Xe, RAM 16 GB.
with Windows 7 Windows 10.

Network Details
FritzBox 7590 Ethernet Connection to QNAP as a Music Server.

Audio Devices
Denon/Heos linked to Router via Ethernet

Library Size
25.000 Tracks

Description of Issue
I am in my free trial, try to Test if Roon works with my devices. If yes, pretty sure to buy a Nucleus. So first I Download 64 Bit Version on my HP Envy, doesn’t work. After that tried 32 Bit Version, doesn’t work too. Then I tried the Server Version (with two Samsung Tablets), but the same effect. Every time I only can see the Roon Logo moving in the Middle of a white field, but no GUI I can go on with.

Please, could someone help me to come up with Roon?

  1. Roon Server does not have a GUI.
  2. I assume that you were uninstalling each package completely before trying the next one?

Hi Geoff,

first of all thanks for your quick answer!

To your response:

  1. I know that Roon Server have no GUI. Thats why i tried this one with my two Samsung Tablets. Same effect.
  2. I do not uninstall, but I followed a Support Ticket answered by your technical support, which means that the installed Roon Folder should be renamed in “Roon_old” and the next Version creates a new Folder.

I think it would be better to completely uninstall a package before installing a different one…

Is Windows 7 supported

Do you have Open GL 3 ? That’s a Roon prerequisite

Okay, thanks. I’ll try and come back to you.

Hi Geoff,

pardon me, I made a mistake in discription above. System is running on windows 10, not Win 7 as mentioned above.

Now I’ve deleted all Roon Packages and tried again the 32 Bit Version, same result as before. Only a white Quader with the Roon Logo in it. No Chance to work with.

I hope you have a good idea what to do right now?

Kind regards

I’m not a member of the Support team, I was just trying to get a bit more information for them. Because you have posted in the Support category of the forum, the team will have been notified, and a member of the Support team should be along to help you further.

Something is preventing Roon from loading application. You have experienced the same behavior with three different packages. Did you even setup Roon initially (specified folder where music is stored)?
First step is to run Windows Updates and ensure that your computer is up to date.

Hi Peter,

no, I’m not Setup Roon in a specefied Folder. Before i did the last Test I mentioned before (with 32 Bit version) I made a complete Update.

The only thing I am not updated is the grafic card, because on the Intel HP is a hint that the download is on my own risk and only for Tests (there is a Warning field I have to mark on).

Kind regards

It is very likely that all your problems are related to older graphic card drivers. Some users experienced similar problems (not exactly the same), but once they upgraded graphic card drivers their problems were fixed. I do not think updating drivers would cause major issues.

  1. Check HP support website and see if they have updated drivers for your laptop.
  2. You can also download drivers from AMD website (HP Envy uses HP Radeon). They have a tool that would detect your card and download compatible drivers.

If you encounter any problems you can revert drivers installation.

  • Before proceeding with driver installation, create Windows Restore Point. Windows has built in backup/restore tool)
  • Also you can revert driver installation through Device Manager > Graphic Card > Drivers Tab

Hi Peter,

Thanks again for your great support!

I updated my grafic card to the newest stand from Intel (24.05.2021), tested again, sadly to say but same result. Only the white plain with the Black Roon Logo in the middle, which is moving a little bit.

After that I’ve deactivated my windows defender - because you’re mentioned before that something is preventin Roon - unfortunately same same :frowning:

I’m stumped…
Hope you have another idea?

Kind regards

Did you enter your Roon credentials at any point of time? My guess is that you did not. If I remember correctly you cannot setup Roon without login in first. There could be couple things that are causing the problem. When Roon starts, it needs to authenticate and verify your login info. This is where it probably fails. In addition, we do not know whether this is UI issue or Roon Core issue

  1. Please ensure that you have a working internet connection on your laptop
  2. Disable firewall on your laptop and on your router
  3. See if folder where Roon is installed has all security permissions setup correctly (right click on folder > properties > security tab (allow Full Control for your UserName)
  4. Start Roon an see if there is any improvement
  5. Try to install UI/Roon on another machine. If it works. that would mean that internet/LAN is not at fault
  6. Install Roon Core on another machine and UI on laptop. Use tablet and see if you can connect to Roon Core

Hello Peter,

Thanks again for your Feedback and Ideas!

I don’t remember all the Tests i’ve made (there was many), but I remember a lot of Logins i have done.

To your instructions in mail above, i have followed:

  • ensure Internet connection > yes
  • disable all firewalls which are possible > yes (not a good feeling)
  • Roon Folder Check > des
    Same result as in all the Tests before

To your point 5.: would you please explain a but more what is the meaning from Machine? Perhaps Tablet? I have no second Notebook with Roon requirements

To 6.: I have tried yesterday, Roon Server installed on my Notebook, App on Samsung Tablet please see my Mails before.

Kind regards

Hi Peter,

since yesterday Roon works, oh what a feeling :slight_smile:

I started the Roon App on my Notebook, but this time I choose an other workaround as the last Tests before: this time bevor I clicked the question “Use your Roon Core on this PC or search for it” I startet the App on my Tablet and there I can connect to the Core on my Notebook. After that now my Notebook works just as well.

Thanks again for your pretty good support all the time!

Two more questions, please: I was wondering that my Denon AVR X 6200W is connecting via Airplay even though it is connected to my Router via Ethernet? And I can’t connect my Heos HS2 - it is connected via Ethernet, too.

Is there a chance to connect Heos? And is a connect with my Denon via Ethernet possible?

Kind regards

1 Like

Hi Markus
I’m glad that it worked out after all.

For your Denon to use anything else than AirPlay, you would need some other streaming device like Bluesound Node or Raspberry Pi. They would have to use some type of cable connection to your receiver. This would bypass AirPlay protocol .

Heos portable speaker would use AirPlay, unless there is way to connect to it other device like Raspberry Pi.

Hi Peter,

I can’t thank you enough for your endorsment!
Thank you, thank you, thank you…

It’s so cool to have a look at all the Roon Features, it is so amazing.

Next step for me is to buy and install a Nucleus, because my Notebook to use as Core is no long term solution. I only want to test how it works during the 14 day free trial. The same time I have to decide to install a raspberry or change my setup, means receiver / portable speakers.

Thanks again, whishing you alle the best
Kind regards
Markus from munich

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.