Roon dropping Sonos endpoint after approx. 20 songs

I have the same issue. I’m still evaluating Roon and functionality and features are perfect for me. The Lost control of the audio device issue with the Sonos players (I want use Roon mostly to play my Redbook and Highres Flacs on a ZP80) appears about every 20 songs I play. The Sonos is unusable after that (also for native Sonos software and Spottify) until I have unplugged the power and restarted after that.

Playin certain MP3’s and/or switching back to flac might be causing this but I cannot be 100% sure. I am sure it does not happen al the time after I have selected MP3.

So please try to fix this problem because I would like to subscribe after my eval period expires.

Hi @Eric_Peters ----- Thank you for chiming and sharing your feedback with us. I have went ahead and split your post out to it’s own thread so we can address this issue with you directly.

Moving forward, to help aide in our understanding of the behavior you are reporting, may I very kindly ask you for the following information:

Setup details and general feedback:

  • A brief but accurate description of your current setup using this link as a guide. I would like to have a better sense of what gear you’re working with.

  • Please describe your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your device are communicating and tools involved in making these connections possible.

  • Do you ever experience any issue while using the Sonos application own it’s on?


  • If the mentioned Sonos endpoint(s) are being accessed via Wifi connection have you tried testing with a hardwired one? If so, what was the experience like?

  • I would like you to please perform the following in both the Roon and Sonos application:

    • Please create a playlist of just MP3s (a few hours worth if possible) and let it play.
    • Please create a playlist of just FLACs (a few hours worth if possible) and let it play.
    • Once the above tests have been ran please let me know what the experience was like in both the Roon and Sonos apps.



Core: Roon Version 1.3 Build 276 Stable (64 bit) running on Mac Mini End 2009, 2,26ghz Core Duo, 8GB Ram, WD Hybrid SSD HD. OSX El Capitan 10.11.6, MacOS server 5.2.

Control 1: Same version Roon running on Macbook Pro Retina early 2014, running High Sierra 10.13.1. (8GB, I7, 500GB SSD) (This one is always loosing connection to Sonos ZP80, Using Coax Digital out to FIIO DAC). This Mac is wired to the main ethernet hub (1gbit)

Control 2: Ipad Air 2 running IOS 11. (Also has lost connection to Songs)

Control 3: Imac, 27", 3.1Ghz i5, 16GB, Igb Fusion Disk, Apogee Duet Dac (Wired to the main hub via extra hub and runs without problems)

Music is stored on share NFS folder on Netgear Readynas 314
Netgear 16 Port Gigabit Switch (2 pcs 8 port switches and one extra POE switch for security cam system)
Wifi Network: Apple Airport Extreme (7.6.8) + 2x wired Airport Express

Player: Sonos ZP 80 Connected wireless to Wired Songs Play 1 (at least thats what I suspect). The songs play 1 is connected to the main switch Through another switch. The ZP80 is not grouped in any way and plays flawless using the songs app or spottily connect.

Player 2: RaspberryPi with Mamboberry LS, Wired 100mbit. (No issues at all)

Player 3: I tested Airplay without issues.

Tage system is currently still running background audio analysis. (about 10k out of 25k tracks)

I’m now testing the Flac playlist with various nitrates and no connection lost up until now

I have run several test now:

1 - Made a Flac only playlist 3 hours long using several sampling frequencies and bit depths, this played without any interruption and continued in radio mode for another 5 hours.
2 - Made an mP3 only playlist also about 3 hours using al kinds of bitrates, also this played without problems and continued in radio mode for a couple of hours.

3: after that I manually played parts of different songs::
1st - Flac 44.1khz/16b khz
2nd - MP3 320khz
3rd - Flac 44.1khz/16b
4th - Flac 96khz / 24b
5th - DSF (DSD64)
6th - DSF (DSD64)
7th - Flac 88khz/24bit -> this would not play anymore, lost connection

After that I restarted and tried again with exactly the same songs from the history page:
Now it lost connection when I selected the 6th Track, so the second DSD track.

Next test: Exactly the same tracks played on a Sonos ZP80 but one which is wired to the network>
I could play everything and much more without interuption, I switched between all formats without any issue.

After that I went back to the wireless one and now it was the 4th track which triggered the connection loss.
So in my mind it is clearly related to the wireless connection and switching to or from a format which cannot be played natively on Sonos and needs some kind of bitrate and or sample rate conversion. I suspect Roon can “prepare” the stream when playing a playlist and cannot if the user randomly changes songsand that is possibly the reason why it only occurs when zapping through music.
Next to that the ZP80 uses an older wireless protocol.

I have plugged a Ethernet cable into the ZP80 with problems.

But the problem re-occured with one thing different:
Now I could regain control using the Sonos App and It says: “playing roon.wav”. If I press play in Sonos I get a message: “song is not encoded correctly”. Switching to the Sonos library worked, switching back to Roon kept giving me the same “lost connection” message, regardless of the track. I have to reboot to be able to play from Roon agin.

[edit] I have now confirmed that wireless has been switched off so I’m using the cable connection. Strangely one ZP80 has problems all the time and another ZP80 has no problems. Both are using Digital out to a Dac (different dac’s but I can’t imagine this can be the issue.) Both hardware and firmware versions are the same and they are both connected to the network through the same model sitcom switch. The only difference I can see is the other equipment connected to the switch and the length of the cables.

Next thing I’m going to do is swap the units.

Hi @Eric_Peters ----- Thank you for the updates and apologies for the wait “here”. Letting you know that I have followed up with you in a PM concerning this issue you have reported with your Sonos endpoint(s) and also your Roon trial period.


Swapping the units did not change anything. The other ZP80 has the same problem, and the old ZP80 also has the problem in the other location. So Both zp 80’s have the problem, in Both locations and it doesn’t matter if they are wired or wireless. The problem only occurs when I’m “zapping” through music in multiple formats. If I let all the songs play all the way most of the time than the problem does not occur or it takes a lot longer before it occurs.

I also spend an hour trying to get a Play 1 (wireless) to get the same problem but this one did not have the problem (or it takes way longer to trigger the problem) So I’m wondering if there is a processor difference between the Connect and Play 1 which might be the main cause.
If I check the device XML description of the devices and the ZP80 has 32mb ram and 32mb Flash, The play one has 128mb Ram and 64mb flash. So maybe the error is related to the lack of memory in the ZP80?

Thank you for touching base with me @Eric_Peters and providing an update on your testing. Very appreciated!

Moving forward, based the information shared in my PM I do believe that the right course of action here is to start looking into your network configuration. When it comes to network troubleshooting we always suggest using the process of elimination to try and determine where things are failing. Making the network configuration as simple as possible, and then adding complexity back into the chain of communication one step at a time. As it stands currently (from your report) your network topology is as follows:

“Netgear 16 Port Gigabit Switch (2 pcs 8 port switches and one extra POE switch for security cam system). Wifi Network: Apple Airport Extreme (7.6.8) + 2x wired Airport Express.”

“Sonos ZP 80 Connected wireless to Wired Songs Play 1 (at least thats what I suspect). The songs play 1 is connected to the main switch Through another switch.”

I would recommend getting your core, NAS, and ZP80s all on single switch mounted directly to your router, first, with all other devices (temporarily) offline. In this configuration confirm how the ZP80s respond. From there, as mentioned, start to expand back out.

Lastly, I just wanted to point out that we have seen some issues in the past related to Apple’s line of networking devices (i.e Apple Airport Extreme (7.6.8) + 2x wired Airport Express), as mentioned in further detail here by our CTO Brian. Now I want to be clear that I am not saying that this is cause of the problem here, just merely sharing some feedback based on previous support issues :wink::innocent:

Looking forward to hearing how your testing goes!

The Apple link describes issues with the Apple wireless, the ZP80 where I have issues have all wireless functions shut off and the signal does not pass any Apple device (this does not guarantee there is no unwanted traffic on the wired ethernet because of the Apple devises.)

All devises that I have which are wireless (3 pcs play1 and a RaspberryPi3) do not have any issues, so I don’t see the point of fixing something which is not broken. I would like to fix what is broken.

Basically from a personal cost/benefit point of view I’m done testing, I would like to listen to music during the spare free time, and not spend all that time testing. And shutting my network basically down and reroute everything just to test something takes way too much time in my case. If you want I’m happy to send you one of my ZP80’s to have it tested by your engineers.

For me a dropped connection is not the biggest issue, the real issue is that I only can reconnect by disconnecting and connecting power of the device which I have installed in a hidden place, except when I wait for a couple of hours. (where all other software can reconnect to this ZP80without problems)

Ps that doesn’t mean I wont subscribe, I like the way I can rediscover my digital too much.

I think I have found the cause of this problem, at least I am now able to trigger the problem on demand…

I think it is strongly related to audio analisys (either background or on the fly when playing a recently added song)
I havent had the issue for an entire week, I actually thought somekind of update had fixed the problem, until today… I have ripped a big bunch of my cd’s last week and have copied the files to my NAS folder, which holds my Roon music, about an hour ago. I wanted to listen to a couple of tracks which were just added to the library and about every other track I had the dropping endpoint message and needed to reboot the sonos device. It immediately struck me that the only thing which was different was that I added quite a lot of files.
When I started looking in detail I noticed that every time when I am playing a track and when I try to switch to another track before the waveform of the current track is visible I get the dropped connection error. I have tried this about 10 times and it happens every time when the waveform is not visible and never (i tried that maybe 100 times) when the wave form is visible from the start or when I wait until the waveform has become visible during playing the track.
When I had the issues previously the system has been analysing audio for almost 2 weeks.

So I hope this helps the developers tracking down the issue.

I haven’t tried to reproduce this with audio analysis running, and I imagine this is probably a CPU/network load problem more than an analysis problem directly, but could you try one more test for me:

It’s possible to turn both the on-demand and background audio analysis off completely in Settings -> Library, could you try that and confirm that the connection doesn’t drop?

I’m still testing this, so this I will edit this later.
Immediately after I turned both audio analysis off I still had the issue but also only when there was no waveform visible and when I switched songs rapidly. I think these were songs with higher sample frequency and/or bitrate than Redbook. What I also noticed is that in the upper right corner of the screen a blinking light was visible with a message that Roon was busy importing music. I found that strange because other than the audio analysis I assumed all music was imported. So maybe it still was working on a batch of music before the analysis ends?

So I decided to wait a while before further testing.

One more thing I would like to add which you might know already: In my mind it is the Sonos device that specifically blocks Roon from getting access. A complete close and restart of the Roon core and clients does not solve the problem, only a power off and on of the Sonos device solves it. Other services like the Sonos app or Spotify connect can get access to the Sonos device also when Roon is blocked.