Roon endpoint dropping connections with Denafrips Pontus II DAC

It’s my first time posting so apologies if I’m not in the right place.
My Pi4 with Ropieee is constantly dropping and loosing connection. I get the message Roon lost control of the device. I have built several Pi4 with Ropiee and this happens on both of my DACs.
Denafrips Pontus II and Chord Dave Dac… I have tried several USB cables and Pi4 power supplies.
Wired ethernet and wireless have the same outcome. I sent a log via the Ropieee interface - ad5c84735b516619 .
Hoping someone can help me out.

Regards, Ray


The Denafrips is known for having issues (on Linux). I see it constantly disconnecting and reports about formats not supported. See if you can find a firmware update for the device.

Now, the Chord should just work (I have one). If you can send me logs with the Chord attached I can have a look.



Thanks for the fast response.

I recently sold the Chord so I won’t be able to try that again

In terms of the Denefrips I did a firmware update a couple of days ago.

It seems to work fine on a Mac Mini I have. I will just swap it to the Mac.

Perhaps Denefrips will fix the issue in the near future. A little disappointed in Denafrips as I was really thinking about getting the flagship model.

One thing to note… the issue is much more common when I use any of the two Final Touch Audio USB cables I own.

When I swap either out for my audioquest carbon the problem is almost alleviated.
All three cables work on the Mac Mini also without issue.


One additional question. I have a Luxman DA-06 DAC.
The 3 pi4 with Ropieee that I have. None of them ever detects or sees the unit.
Any insight into that issue?


We have multiple customers using this DAC (and other Luxman DAC) with our streamers, so Linux compatibility should not be an issue.

Try using a USB computer printer cable.


Thanks…seems your suggestion has solved both of my issues.
Wow what to do now with three very expensive USB cables. I do hear a decline in sound quality from the printer cable. I guess I need to decide… stick with Pi4 and USB printer or Mac Mini , Intel Nuc and my audiophile USB cables. Decisions.

Thanks again,


Maybe consider a low to middle ground USB cable.
A step above the freebie stuff but way below boutique level.
I use a 1.5m USB cable from Pangea, think it was $40 or so?
I honestly could hear no difference between this and the $200 AQ Carbon so I sold it.

I second Kevin’s suggestion. I’ve had vey good results with a $40 Pangea USB cable.

1 Like

I’m OK with the sound results of the USB printer cable as it was a $10 cable. I’m also ok with the fact that an $800 boutique cable sounds slightly better as I chose to spend that money of my own free will. What I’m not OK with is that an $800 dollar boutique cable does not work properly.

Sound quality is subjective but operational stability should be a given at those price points.

Just my two cents.

I’m the last person who would criticize how anyone else spends their money, especially when it comes to audio gear.
After all $3k for a phono cartridge will have some people here wanting to commit me to a funny farm…lol.

All I was suggesting was as a trial just to see if sq and functionality were restored with a Pangea level cable.

Enjoy the music!


I understood what you meant and I will actually try out a Pangea. The funny thing is all the cables seem to work on my Mac Mini and Intel Nucs but not on my 3 pi4 with Ropieee lol. Anyway thank you all for your support. I’m just going to go listen to music now.

Regards, Ray

1 Like

I’m using a $10 Monolith USB cable (1 meter) from Monoprice. It’s a well built cable and has worked flawlessly on both my DACs - including a Denafrips Ares II.

Monolith by Monoprice

Thomas… Thanks for the info. I actually sorted things out I found that with all 3 of my Pi4 that they are all very sensitive to the DAC (Denafrips Pontus II and Luxman DAC-06) and different USB Cables. I tested each usb connector separately on each Pi4 with Ropieee and with my 2 Final Touch Audio USB Cables and was able to find a stable connection with one of the four USB connectors on each of my Pi4. I have been listening for several days with out a connection drop. I have no explanation to why this is the case.

My generic cable have no issues with either DAC or Pi4 but definitely does not sound as refine as my other USB cables. And as i mentioned earlier in the post I have no issues what so ever if I run my DACS off a Mac Mini or an Intel NUC with any USB cable I tried. In the end it all sorted out but it took quite a bit of testing and AB-ing to figure it all out.

Again thanks for your reply!


Raymond if you want to use a Streamer that Costs almost as much as one of your cables maybe you should upgrade from a Pi to the iFi Zen streamer, though as streamers go it’s still fairly cheap and built using high quality components. Might be worth an upgrade to give your cables a work out

Yeah that is on my mine. I own the Luxman DAC and its normally connected to my Intel Rock Roon Core directly. The Pontus II is in for evaluation if i keep it I might go down that road as its for a third system. I’m an IT professional/Engineer so I might give it a go and build a fanless Intel NUC Endpoint with linear power supply and see how that goes in terms of sound quality. I’ve been playing with the Pi4 and had them around the house so i put them to use. To my surprise I would never have imagined how sensitive they would be to USB cables as I have them controlling all sorts of other non audio devices all over my house.

1 Like

Raymond that is exactly what I have built and I am very happy with it.
I have to say the LPS for the core is not necessary, unless you want to run an endpoint off it. But you are probably better off. Breaking the Core and streamer apart that fits with the Roon recommend model.

The Pi devices are great but at a price point, maybe not meant to run cables that cost 8 times the price of the Pi.