Roon endpoint losing connection constantly

Core Machine (Operating system/System info/Roon build number)

OS Name Microsoft Windows 10 Pro
Version 10.0.18362 Build 18362
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-37T07CL
System Manufacturer Gigabyte Technology Co., Ltd.
System Model To be filled by O.E.M.
System Type x64-based PC
System SKU To be filled by O.E.M.
Processor AMD FX™-8350 Eight-Core Processor, 4000 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. F1, 3/17/2015
SMBIOS Version 2.7
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer Gigabyte Technology Co., Ltd.
BaseBoard Product 990FXA-UD3 R5
BaseBoard Version x.x
Platform Role Desktop
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = “10.0.18362.752”
User Name DESKTOP-37T07CL\bl4sc
Time Zone Pacific Daylight Time
Installed Physical Memory (RAM) 24.0 GB
Total Physical Memory 24.0 GB
Available Physical Memory 15.1 GB
Total Virtual Memory 27.5 GB
Available Virtual Memory 16.7 GB
Page File Space 3.50 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not Modern Standby, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Xfinity Wireless Gateway (Black Model)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Dell I7 Laptop, Nvidia Shield connected via HDMI, Oneplus 7Pro (used as remote and endpoint with DragonFly Red)

Description Of Issue

Having issues on all endpoint devices: Dell Laptop with DragonFly Red Connected, Android phone as interface connected to Nvidia Shield

Connection Lost. In some cases it will come back quickly and in other cases I will need to close the app down and restart

Dell Laptop, Have allowed access to Roon and RAAT.

Seeing errors in Log: Broker Lost and Connection Lost

Hi @Brian_Scott,

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

How is the Dell laptop connected to the router? Over WiFi or Ethernet? Is there any change in behavior if you temporarily connect via Ethernet if you’re currently on WiFi?

Thank you for the information. I checked the PC that is the Roon server and it was connected via Private network and both Roon and RAAT were already on the exception list. I am running Avast and added those two as exceptions as well.

Regarding my laptop (work), I am unable to add these two as exceptions as I do not have admin access. As I work from home, and want to play music through my work pc via dragonfly, I have been simply disabling my windows defender during that time period. Malwarebytes is also installed and I am unable disable or add exceptions to this without admin access.

I am seeing similar connection issues with my android phone, but have read these do not always play well.

I have purchased a Ropiee that will be here Friday that will connect to my av receiver (hoping not to have connection issues this way)

The work laptop is connected via wifi but I will be testing the connection issues via LAN connection later and report back.

Again thank you for the help as I am loving Roon and really want this to work successfully.


1 Like

Do let me know how this goes!

Yes, if you can use the Ropieee instead of the work laptop, that could eliminate some possibility of what is going wrong such as security software on the laptop.

I am still having connection issues on all devices (Ropiee) not used enough to make determine yet. Affected devices are Windows laptop, Ipad, and Android phone.

Recent log from laptop is showing:
7/13 12:11:29 Info: [brokerclient] Connection dropped: DESKTOP-37T07CL (40b37eff-116f-48e9-a18c-4469313c2d47) @
07/13 12:11:30 Info: [brokerclient] connecting to DESKTOP-37T07CL (40b37eff-116f-48e9-a18c-4469313c2d47) @ (attempt 1/6)
07/13 12:11:30 Info: SuspendZones
07/13 12:11:30 Info: [client/root] Broker changed DESKTOP-37T07CL (Remote Broker 40b37eff-116f-48e9-a18c-4469313c2d47) => null
07/13 12:11:30 Info: [client/root] Client is acting as a remote
07/13 12:11:30 Info: [client/root] Broker ready changed True => False
07/13 12:11:30 Trace: [push] restarting connection (Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)
07/13 12:11:30 Debug: trigger: appinitwasrun
07/13 12:11:30 Debug: trigger: no broker
07/13 12:11:30 Trace: [push] retrying connection in 2722ms
07/13 12:11:33 Debug: GETKEY. KeyToChar(F15, False, False) ->
07/13 12:11:35 Info: [distributedbroker] LOST BROKER DESKTOP-37T07CL (40b37eff-116f-48e9-a18c-4469313c2d47)
07/13 12:11:40 Trace: Successful POST response from
07/13 12:11:40 Trace: [push] connecting to
07/13 12:11:40 Trace: [push] connected
07/13 12:11:41 Debug: render area size changed value: 1536x779.2
07/13 12:11:42 Info: [stats] 5401mb Virtual, 357mb Physical, 70mb Managed, 1324 Handles, 67 Threads

Any ideas?

Hi @Brian_Scott,

That trace suggests that the remote is disconnecting from the Core and it looks like you’re also losing contact to our servers around the same time as well.

Did you get a chance to try out my previous suggestion and connect the Core + Remote via Ethernet cable instead of WiFi?

My shield is hard wired as well as the Ropiee XL but all other devices are wifi. I did try your suggestion and connected the laptop to ethernet and encountered the same issue.

Hi @Brian_Scott,

Do you have the latest firmware version installed on your router?

I do yes. I changed sleep settings on my HD’s to ensure they were not sleeping and causing issues.

Hi @Brian_Scott,

Do you have another non-work PC you can try installing Roon on? I wonder if this issue is due to an interaction with some of the firewall software your company might have on the PC.

I have tried it on other laptops, Chromebook, iPad and Android phone and all disconnect. Many times it will quickly reconnect but other times it can take 45-60 seconds.

Hi @Brian_Scott,

Yes, I understand that you tried the Roon app there, but have you tried changing the Core to one of the non work PC’s?

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

My core is on a personal PC that is running my Plex server. I will try installing and creating a new core on a different PC and report back results.

1 Like


I wanted to report back. After installing a Core onto another PC with no library attached but having Tidal signed in, I did not receive a loss of connection.

Current I am having less issues recently but still having disconnects. Today I am streaming from work laptop to Core PC and lost connection.

Here is the last part of the log:
08/24 13:32:30 Debug: UI-FWD: skipping fwd2 due to lazyload: queue
08/24 13:32:30 Debug: GMS: found currentscreen in GMS file, going to index 18
08/24 13:32:30 Debug: UI-FORCE-UNLAZY: mode: queue
08/24 13:32:30 Debug: UI-NAV: queue
08/24 13:32:30 Debug: GMS: trying to save nav stack, but nav stack stuff was in progress
08/24 13:32:30 Debug: UI-NAV: queue
08/24 13:32:30 Debug: GMS: done restoring nav stack
08/24 13:32:31 Warn: [remoting] missing property bool? Sooloos.Broker.Api.Performance::IsComplete on type Sooloos.Broker.Api.Performance
08/24 13:32:31 Debug: [easyhttp] [43] POST to,roon.debug.,roon.client.,,roon.dsp.,roon.sood?roon_auth_token=41739d15-5696-4b6d-ab15-09bc96113de7 returned after 856 ms, status code: 200
08/24 13:32:31 Trace: [bits] updated bits, in 859ms
08/24 13:32:32 Debug: GMS: saving nav stack
08/24 13:32:32 Debug: GMS: trying to save nav stack, but nav stack stuff was in progress
08/24 13:32:33 Debug: GMS: done saving nav stack
08/24 13:32:37 Info: [stats] 5669mb Virtual, 780mb Physical, 171mb Managed, 1355 Handles, 57 Threads
08/24 13:32:40 Trace: Successful POST response from
08/24 13:32:40 Trace: [push] connecting to
08/24 13:32:41 Trace: [push] connected

Both devices are hard wired. My android device seems to have the biggest issue with constant loss of connections.

Thanks again,


Hi @Brian_Scott,

Can you please provide a .zip archive of the full log package on both the Core and the Client PC? I would like to ask QA to review them, thanks!

I figured out it was a issue with my motherboard network adapter. Upgraded motherboard cpu and ram and all seems to sing.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.