Roon Essentials won't allow Tidal login - Bad username or password

Thank you for the quick response. If possible please would you notify in here once a solution has been found, which would be really helpful? Many thanks.

I am not working at any of the listed companies but I will try to update it here.

That would be FAB thank you so much.

Core Machine (Operating system/System info/Roon build number)
Core: Elac Discovery DS-S101-G
Roon 1.5 (build 49) stable (32bit)
Firmware Version 1.3 (build 28) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Connected via ethernet cable directly to router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
via optical output to amplifier

Description Of Issue
Hello guys

I am having since a few weeks sometimes connectivy issues as that Roon (on my ipad app) doesn’t play songs or skips them by saying network / connectivity problems or data stream problems. Usually they went away or a reboot of router and Elac solved the problem.

Not today. I rebooted both devices 3x. I cleared the cache of my Elac device in the settings. But it would not play any online song. Songs on a USB stick with FLACS I got connected to the Elac work fine. So the Elac device is working.
Now I logged out of Tidal in the settings of Elac (Ipad app) and I can’t login anymore. It says wrong user name. I checked on my mobile phone and I can login just fine. I also checked on my computer and I can login fine with my usual email&password.
So there seems to be a problem on my Roon on the Elac.

Thank you for any help!

Michel

Same issue - I logged out of Roon Essentials and cannot log back in … no communication from Elac even thought they have all users email addresses . Support web site acknowledges issues but does not have any dates as to when issue started or fix timeframes.

Hi everyone, thanks for reaching out. We are currently working with Elac on this and we’ll be sure to keep everyone updated when there is more information!

Elac abandoned Discovery/Roon Essentials long time ago after making their profit. They are a useless company when it comes to support. They cannot even keep their support forums clean. It is full of porn and junk messages. Elac should be ashamed of themselves. If it weren’t me, they had no idea what was going on. The chat support (surprisingly I could get help from someone) had no idea until I was explaining what was going on. The person tried with his own Discovery unit and couldn’t sign back in. Then they addressed the problem. I wish Roon never did partnership with Elac.

Roon Essentials / ELAC Discovery Server
Not able to log in to TIDAL

I am having the same issues. Its been going on for days now. This is really annoying at this point. There is very little help from Roon, and absolutely no help from ELAC.

(For public knowledge: I think ELAC makes great products, but they have horrible to non-existent customer support after the sale. If you purchase a product that you might expect to have to need interaction with the company over, go with someone other than ELAC.)

1 Like

I am having the same problem, so if you can let me know when a solution is reached that would be very nice.

Roon told me Fault User Name and Wrong Password !

Booth is right !

Have Start my Elac many Times new I start my Essential App 100 Times !

No Chance ! Whats the problem ?

Oli

1 Like

I have the same problem, my device is elac discovery ds-s101-g has been 2 days

Tidal has upped the prices and therefore you have to agree to the new pricing. Here in Europe it has gone up quite considerably, from 20 Euros (19,99) to 26 Euros per month. That is a 30% price hike.

I’m considering trying Qobuz instead.

From Elac:

Thank You !

Then Hurry Up !
:wink:

I have no relation with any of the companies. I am just a user like you:)

HaHa…Sorry,Sorry !
Your r right ! Forgive me !!!

1 Like

It passes 3 days …! And it is not possible to Sign in in my Tidal Account !

User Name or PWD wrong!
It is Absolutely right : I can sign In with my data on the Tidal Website!

I reboot my Elac a million Times!
I Sign in and out in my Essential Account!
No Chance!
And yes…my Network and my Internet works fine :wink:

What s going on???

In the Forum I read there is a Problem between Elac, Tidal and Roon!!!

At the moment there iss a big Problem for THE USERS !!!

1 Like

I’ve tided some duplicates and merged then remaining cross postings to this topic so all the history is together.

For those that may have missed it … see Dylan’s post …

From what I understand, Tidal changed their login protocol and this messed up everything. I think if Tidal does not respond to the problem, we will have to wait. It is all on Tidal now.

Core Machine (Operating system/System info/Roon build number)
Elac Discovery DS-S-101G
Roon Essentials on Elac Discovery v1.5
Iphone 8: v1.5
App firmware build v1.3 build 28

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Netgear
gs105e

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

B&O, cd player / dac
digitale connected with Elac Discovery
connected with internet cable via netgear to the router

Tidal interference issue
Tidal is not being recognised
tried to solve it
used a different internet cable, no success…
Disconnected tidal service but reconnection failed
Tidal account with the Tidal app is still active and working, so my account is active…but not with Essentials…

Very annoying!
Others:
Text is in white letter instead of black