Roon.exe turns to Run.exe.old every day

Hi there,
I’ve been using Roon for about four years now, but there’s a problem with the software that keep comin’ up.
The thing is… every day I have to rename Roon.exe.old to Roon.exe for it to work.
It’s kind of annoying, you know.
Runnin’ through knowledge base and everything, I have not come up with an ultimate solution.
Should this go on, I’ll be compelled to remove the whole thing for good, which I wouldn’t want to, of course.
Could you provide some help!
Thank you!

Some system details of your Core would be useful.
What exactly are the symptoms that lead you to do this?
Has it ever worked properly and if so when did the issue start?

Moved to support area.

1 Like

I run Roon.exe on Windows 10 64bit

It has worked properly for some time, but the problem keeps comin’ back.
As to what symptons, nothin’, the desktop link goes off and I have to rename the Roon.exe.old file for the whole thing to work


What desktop link? A Windows shortcut?
Did you create the shortcut?
Do you run an AV program?

Can you run Roon from the start menu (or whatever Microsoft call it these days) without renaming anything?

yes… the desktop shortcut cuts off every time I turn Roon off.
The shortcut I didn’t create, but it needs to be remade every time.
I run run the software from my PC to an outside (cabled) DAC

What happens if you install the shortcut for Roon down onto the taskbar?
That’s where I put mine on both Win10 64 bit PC.

same deal man. I think it’s a software engineering problem, best guess

It’s definitely an odd fish for sure!

It sounds like an update is trying to happen and failing leaving the old exe renamed. In Roon go to about, on the core click the gear and set it to ask before downloading. Then see if the shortcut remains stable overnight.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.