Roon Extension: Alarm Clock v0.7.2


(Rene Bouwmeester) #41

First sleep fade in 10… 9… 8…


(Jan Koudijs) #42

Your alarm says Play (wake) not Stop (sleep)…


(Rene Bouwmeester) #43

Not any more. :smiley:

At the designated time, it comes to a ‘hard’ stop (Good. Stop is good. ;-)). I’ve set fade time to 10, but it does not appear to have any effect. (Zone is a RPI2/Digi+, volume control set to DSP volume for the experiment).


(Rene Bouwmeester) #44

Play works fine as well.

One thing I noticed: the time that is set after entering a time in the settings panel is 1 min. off:


(Jan Koudijs) #45

Can the volume be controlled via Roon is this mode?

I have tested it mainly on my NUC6i5 via the analog output. I now tried a fade-out on my PS Audio DAC, here the fading stops after a while. I have to dive into this…

This 1 minute is the fade time. The set time tells when the set volume will be reached, the status shows when the fading starts. This simplified the implementation, I will see if I can improve this.


(Rene Bouwmeester) #46

Yes. I usually have it set to fixed, but in the bedroom I use DSP volume since audio purity matters less than being able to control the volume from the eh… bed.

Clear. I think the implementation is fine – just a bit of explanation needed.


#47

I installed the https://nodejs.org/
Inside the same folder I made a new folder where I paste the unzipped https://github.com/TheAppgineer/roon-extension-alarm-clock/archive/master.zip

What next should I do ?

Probably I don’t understand item 5 & 6 in your userguide :slight_smile:


(Jan Koudijs) #48

In step 4 you have to open a Windows Command (cmd.exe) window, there you have to change directory to the ‘roon-extension-alarm-clock’ directory. From that directory you first run ‘npm install’ and after that ‘node .’ (The space and dot are part of the command!).

I’m using a Linux machine, so I could not test the installation under Windows.


Anyone willing to coach a total n00b in using the API?
#49

Thanks

I’m quite sure I’ve done this correct now. Tried both nodejs versions available and get the same errors both times.

Would you like some logfiles ?
(Edit: Sent on message to you)

I’m running W10, but my Roon core is on a Sonictransporter or a qnap.
Both which either would require modifications either by @agillis or @crieke, so I would expect this to work on a W10 as I guess we’re to early to expect SonicOrbiter support (Already confirmed by Jesus in CA site) and qpck modifications if that is the case at all.

@RBM ; Did you make this work on a W10 installation ?


(Jan Koudijs) #50

I can’t tell from the logs what’s going wrong.

What if you try it like this:

  • Extract the zip file somewhere in your ‘My Documents’ folder

  • Open the Windows Explorer and browse to the extension folder at the extraction location, this is the folder that contains the package.json and alarm-clock.js file

  • At the top of the Explorer window you have the current path (something like ‘My Documents\roon-extension-alarm-clock-master’. Click on the empty space behind the path, that should give you the possibility to enter text.

  • Remove the path, type ‘cmd.exe’ and press enter, you should now get a command window with the extension path already selected.

  • Type ‘npm install’ and press enter, wait till the command prompt returns

  • Type ‘npm .’ and press enter (don’t forget the space and dot at the end of the command). Ping messages should start appearing:

    <- REQUEST 3 com.roonlabs.ping:1/ping
    -> COMPLETE 3 Success
    <- REQUEST 4 com.roonlabs.ping:1/ping
    -> COMPLETE 4 Success
    <- REQUEST 5 com.roonlabs.ping:1/ping
    -> COMPLETE 5 Success

If this still doesn’t work a Windows 10 user has to jump in.


#51

Like this ?

or this…

Why can’t I use this ?
It’s the same you’re asking ?

And then getting this as before:

End of file looks like this:

Text in red:

npm ERR! git clone --template=C:\Users\Foobar\AppData\Roaming\npm-cache_git-remotes_templates --mirror https://github.com/roonlabs/node-roon-api-transport.git C:\Users\Foobar\AppData\Roaming\npm-cache_git-remotes\git-https-github-com-roonlabs-node-roon-api-transport-git-8f45bd39: undef


(Rene Bouwmeester) #52

You need git:

https://git-scm.com/download/win


#53

Did that. Huge amount of SW. Now what ?
Cause repeating npm install was not an option :slight_smile:

WAIT

Now working :slight_smile:


(Jan Koudijs) #54

Thanks for providing the missing link Rene, I will update the instructions.

Nice


#55

And yes, can aslo confirm my Roon on my iPad via SonicTransporter i5 is working :slight_smile:

Thanks for help.


#56

Just if any wonder you do not start the normal CMD but the one given by “GIT”

I did not change anyting during instalation. Left everyting as defalt during installation.

And then the instructions is the same.

So now we only need a Mac user to test :slight_smile:


(Rene Bouwmeester) #57

It works. :slight_smile:


#58

On a Mac ? :blush:


(Rene Bouwmeester) #59

Yes, this is a Mac.

Not surprising, as Node.js and git are well known tools that work fine across platforms.

But the proof of the pudding: dare I trust @Jan_Koudijs to wake me up monday morning? :smiley:

More seriously: I like your pioneering spirit quite a bit, Jan. This is a nice bit of foreshadowing of what will be possible with Roon over time.


#60

VV[quote=“Jan_Koudijs, post:40, topic:21556”]
Start off by performing a basic test. Set up a non-critical alarm to start or stop playback and see if it works for you.
[/quote]

Jan

Can you add “Today” as an option. That will be quite usefully as well. Unless I’ve missed how to do.
If I understand this correct, I can only set alarms for next day, meaning it has to be after midnight. Correct ?

If you like further challenges, you probably could connect this to your calendar or birthdays, etc. (Not that I will use. It’s enough with the smartphone ).

A count down timer could be an option to the today request above ?
(I can’t wait to see of this really works) :slight_smile:

EDIT:

I may misunderstood how it works. If you put on fade, that will start be forfore your wake up time.

So no none for a today. Sorry for the confusion.

What I did first was to set the wake up shorter that the fade in. Then I got one week ahead. Quite logically.

But maybe add an option set stop after xx minutes ?