Roon Extension: Alarm Clock v0.7.2


(Mr Fix It ) #161

I invisioned this being asked sooner than later and here we are :slight_smile: you might be SOL till the extension is certified by roon for inclusion, but that’s only a guess.


(Christopher Rieke) #162

I think there is currently no way to run it directly on ROCK. But you can run it on any other device in your network, that has nodejs (installed as written in the Roon API readme on GitHub). It is not required for extensions to be executed on the Core.


(Mr Fix It ) #163

Ah that’s interesting


(Jan Koudijs) #164

As ROCK doesn’t support installation of 3th party software, it is at this moment not possible to run the Alarm Clock extension on it. Even if there was a way to ‘hack it in’ it still would be gone at the next ROCK update. So the final solution should be that it is an integral part of ROCK, but no clue if and when this will happen.

But as @crieke already said, you can run it on any PC or endpoint in your network that has node.js installed. My current approach for making extensions more accessible for users is to get them pre-installed on servers and endpoints. I’m already in contact with @spockfish to get it included in his RoPieee endpoint image for the Raspberry Pi. The idea is to come up with a system that wraps an extension installer in a Roon extension. This make extensions manageable (install, update, uninstall) from within the Roon interface.


(Danny Dulai) #165

it will happen… we have a sandboxing environment plan to do exactly this. this project was one of the reasons that ROCK got delayed in release… we decided to push it off to a later release so we could get ROCK released!


#166

Is it Rock spesific, or Roon core in general ?


(Danny Dulai) #167

ROCK – we can’t sandbox stuff on your unknown operating system setup.

On your own Linux/Windows/Mac setup, you have the option to run extensions as you want, and you are free to manage the risk associated with that yourself.

We don’t give that you that option on ROCK, so it’s up to us to come up with that management/risk mitigation system.


(Rene Bouwmeester) #168

@Jan_Koudijs: most of the time when I set a (fading) alarm, it does not show (Status: No active alarms). It does work though: music starts fading out at the chosen time.

Using 0.5.0 via extension manager 0.1.0.


(Jan Koudijs) #169

Is this while the fading is in progress, or also before that?

The status already turns to ‘no active alarms’ at the time the fading starts, some room for improvement here.


(Rene Bouwmeester) #170

Before. I usually tend to listen to music a bit, then set the alarm to play for 10 more minutes and fade 30 after that.

When saving the alarm, it shows ‘No active alarms’. After 10 minutes the fading starts like clockwork. :slight_smile:


(Jan Koudijs) #171

Never seen that happening.
Is there only one alarm enabled?


(Rene Bouwmeester) #172

Yup.

I’ll keep an eye on it to see if and how it’s reproducible. For now, restarting the service makes the alarm appear.


(Jan Koudijs) #173

In version 0.5.0 I changed the status reporting, all pending alarms are reported instead of only the first one to occur. Looks like there is an issue in this part of the code, I will have a look at it. If you can find a way to reproduce, that would be of great help.


(Mr Fix It ) #174

@Jan_Koudijs Hi Jan … I just updated to v0.5.0 finally and note that you can’t pair the extension on 2 cores at the same time. How do I do this or it is even possible?


(Jan Koudijs) #175

Hi @wizardofoz,

I never considered the ‘two core’ case and had a look at the API documentation to find out a bit about it.

The core interface I’m using at the moment indeed only permits one connection at a time. There seems to be an alternative to support multiple, but it would add complexity for a not so typical use case (I guess). I will keep it in mind, but it is not on the top of my list.


(Mr Fix It ) #176

No Biggie Jan … Just thought I would ask.


(Rene Bouwmeester) #177

I tried to find rhyme and reason, but found nothing specific really. It works for a bit after a fresh start, but usually from the next day on, it just shows ‘No active alarms’ after setting the fading stop. Same story when I restart the extension.

I use your extension manager these days, started with forever (with a @reboot in crontab). Works brilliantly, but same behaviour as above.

Just reporting – the alarms themselves work fine.

Once again – thanks for your efforts!


(Jeffrey Robbins) #178

Crew, I have run into installation issues with the npm install command. W2012R2. The error says:

npm enoent ENOENT: no such file or directory, open ‘c:\Users\Administrator.CAPSZUMA\Downloads\roon-extension-alarm-clock-master\package.json’

npm roon-extension-alarm-clock-master No description

npm roon-extension-alarm-clock-master No repository field.

npm roon-extension-alarm-clock-master No README data

npm roon-extension-alarm-clock-master No license field.

So, what do I do now? Thanks. JCR


(Jan Koudijs) #179

Hi @Jeffrey_Robbins,

On Windows you have to run the npm install command from the Git CMD window, this should be installed as part of the git installation.

Let me know if this solves the problem.


(Jeffrey Robbins) #180

@Jan_Koudijs Indeed the alarm settings now appears in Roon desktop settings/extensions.

Thank you.

Two following questions:

  1. It appears that the git cmd pinging window must be left open at all times or the extension shuts down. This is normal?

  2. How do I find the extension on my iPhone, as that would be more useful to me than just on my PC desktop?

Thanks. JCR