Roon Extension: Alarm Clock v0.7.4

(Jan Koudijs) #181

Yes, this is normal.

I read in one of the API threads that the extensions are not accessible from the iPhone app, so currently you have to fall back to your PC.

(Luke Clancy) #182

I think this is exactly what ive been looking for (cant believe its not implemented as standard).

But i have a bit of an installation problem. Following your instructions here:

I have got most of the way (i think). But when i come to step 7

  1. Run it!

node .

Im not sure what im running. I issued the command “node” which did not throw any alert, but also did not seem to have installed anything in my roon…You may have guess, Im following a bit blindly here. Any hints on what i am missing?

(Rene Bouwmeester) #183

The ‘.’ is important – make sure you enter it as node-space-dot.

(Wim) #184

I love this extension but I have to re-enable the alarm about every other week.
Does anyone have an idea why it gets disabled?
Running Roon ROCK on an Intel NUC7i7BNH.
Running Node JS/RoonExtensions on an HP MicroServer N54L gen 7 running Windows 10 Pro.

(Jan Koudijs) #185

Hi Wim,

To be sure, you have repeat enabled for the alarm?

If you have, can you share the alarm settings that you use?

(Wim) #186

Hi Jan,
Today the MicroServer was updated to Windows build 1803 and all extensions have disappeared.
I suppose I need to restart the services.
When I run roon-extension-manager, the extensions re-appear in Roon:

When I close the DOS box all extensions disappear again.

Alarm Clock settings are as follows:

OK, I understand I need to enable “repeat”.

But how to reneable the extensions? Re-install?

Output is found here:

(Jan Koudijs) #187

Yep, if you enable it the alarm will also work for upcoming weeks (no automatic disable).

First check the status of the service:

  • Type services in the Windows search bar and open the Services application
  • Search the Roon Extension Manager in the list and start it if it was stopped

If it is no longer in the list then a reinstall might be required. You do this by following the uninstall instructions and then run the installer again.

The log file looks OK.

(Wim) #188

Hi Jan,
I reinstalled the Extension Manager.
Everything looks OK, but during install I saw the following warnings and errors:

Probably nothing to worry about.
Thanks for you help.

(Jan Koudijs) #189

Alarm Clock v0.6.0 is now available

It’s been a while since the last update but now I have something new.

Some power users were limited by the maximum of 5 alarms, so now I increased it to 10.

To prevent that everyone has to deal with a long alarm list I made it a bit dynamic. After the update you will have the number of previously used alarms plus one. This free entry at the end of the list will be followed up by a new free entry when it is put into use (i.e. the zone has been configured). The adding of entries stops when the maximum of 10 is reached.

I hope you like it.

How to install / update

The recommended way to install or update is via the Roon Extension Manager.

If the manager has auto update enabled then the changes will be pulled in the next time the update is performed. It is also possible to update manually via the Settings dialog, select the Alarm Clock from the Playback category and perform the update action.

(Mr Fix It ) #190

Mine appears to have updated automagically so thats all working as setup.

I now only see 2 alarms one thats settable (now active and a 2nd one where there used to be 5 so that dynamic part also seems to be working.

Nice update @Jan_Koudijs :fireworks: :mage:

(Nathan Wilkes) #191

@Jan_Koudijs, strange problem in the last few days. My long standing alarm only works 50%: the on is always successful, but the subsequent off fails. I have tried setting the off alarm again, rebooting the RP3 (running DietPi, updated to latest for good measure), and rebooting Roon Core. Any other suggestions on what I can look for or try?

Thank you very much. Nathan

(Bart Verhoeven) #192

@Jan_Koudijs Question regarding installing the extension manager. For those using npm for other purposes, would it not suffice to simply install the manager locally (ie. omitting the -g flag)?

(Jan Koudijs) #193

So the music keeps on playing? To be sure, the play and stop alarm act on the same zone? What is the time between the play and the stop action?

(Jan Koudijs) #194

Unfortunately that won’t work because the extensions you install with it will still be installed globally. It also uses global queries to see what is already installed etc.

Those other purposes also require global installation?

(Nathan Wilkes) #195

Hello @Jan_Koudijs,

Yes, the music keeps playing, on the same zone. The time between is 15 minutes, and has been working for a very long time.

I am wondering whether I have some network issues at play, because I am also having trouble with my RoPieee displays (at times).

(Jan Koudijs) #196

Strange, the extension hasn’t changed in the last 2 months. I’m afraid I have nothing to suggest at the moment :frowning: (will get back to you if this changes).

Also running it on the Pi for a long time?

(Nathan Wilkes) #197

Yes, on a (mostly) dedicated Zero W. Starting the alarm always works, so a bit strange.

(Bart Verhoeven) #198

Thanks for the clarification. If it uses the -g flag to install the extensions, then that makes total sense. Mainly trying to run roon extension manager and its installed extensions in an isolated environment.

Not a single one (apart from some general purpose packages) :slight_smile:

I made it work by setting the prefix environment variable (export NPM_CONFIG_PREFIX=~/.RoonExtension). This is also covered in the manual installation instructions.

I would rather make ‘an isolated environment’ part of the default installation instructions as to make sure it doesn’t interfere with other projects, or the other way round, the other projects somehow interfere with yours.

(Jan Koudijs) #199

If that’s the goal then my advice is to run the Docker image:

(Nathan Wilkes) #200

Hello @Jan_Koudijs, ever since the recent Roon update the alarm clock extension seems to keep crashing. Are you aware of any issue or change with the update?


Roon alarm clock stopped working
Error since update to Roon (354): Extensions stop working when closing windows version of Roon