Roon Extension: Alarm Clock v0.7.4


#222

Will do tonight, after work. Thanks for the reply!


#223

Thanks. All is wired with the exception of the tablet that has the control app.


#224

Here it is:

I went into settings => extensions last night and it was empty. Logged into NAS and found Docker running but needing an update. Updated, set the alarm you see. Waited a minute past the set time with music not stopping.

Hopefully the extension disappearing was an anomaly.


(Jan Koudijs) #225

Did the time that was displayed in the status line of the extension after pressing the Save button match the 07:13 setting?

Can you check the log of the container for errors? If you can upload it somewhere then I will have a look.


#226

Following up a remark by @Anthony_Cimino I found out about this strange behaviour:
grafik

grafik
Core running on a QNAP-NAS with proper time-zone setup; Extension is running in a Docker image on Core with time-zone information set; Roon Remote is on Windows.

Alarm goes off at the Time (15:55) in the status line. My TZ is GMT +1.


#227

Hi Jan,

Sent a link to the log file by PM.

The times you asked about did match. Something funny with time though. If I choose “once” the result is Wed (tomorrow) instead of today.

I tried two containers for TZ setting. One with “Alaska”, the other with " UTC−09:00". Didn’t work either way. You may see one alarm with 06:42 instead of 18:42 in the log. I realized and tried again with the right time.

I hope using “Alaska” as TZ is good, particularly if it automatically accounts for DST time changes.

Thanks for taking a look! …Pete


(Jan Koudijs) #228

If you open a console on the container and enter the date command, do you get the expected time?

I don’t know if a console is available via the QNAP interface. If you have an ssh connection then you can use a command like this:

docker exec -it roon-extension-alarm-clock sh

#229
~/.RoonExtensions/lib # date
Wed Mar 13 16:55:06 GMT 2019

Which is correct (GMT time) but not my local time.


#230

It seemed that my image was outdated. I deleted my old Docker container, pulled a new image and setup a new container. I also updated my Docker Compose configuration in the other thread. Now all works as expected. :crossed_fingers:


(Jan Koudijs) #231

There was a timezone bug fixed in version 0.3.2 of the Extension Manager image, so if you were running an older version then that explains.


#232

It was 5 or 6 months old. By choosing the :latest label I assumed that Docker would somehow update the image if not while running so at least on restarts. Apparently I was wrong. :slightly_frowning_face: