Roon Extension: Alarm Clock v0.9.1 (current)

I never checked this, so I am curious about what you found out this morning.

I think that a good indication would be to check if the grouped zone is included in the Zone dropdown in the extension setup.

It just worked. :+1:
Now music in the bathroom is synced with the bedroom.
The grouped zone is not in the Zone dropdown though.

Curious — did you select the primary zone, or the added zone?

I did not change the settings, just grouped the two endpoints in Roon.

Hi @Jan_Koudijs,

Sorry to disturb you but I’m having a problem with the Alarm Clock extension. In the past few weeks it has happened three times that the music stopped after some 10 to 30 seconds, while the fade-in was still in progress. I use three Sonos zones grouped as one: Slaapkamer, Keuken and Badkamer. This morning the music paused at 14 seconds into the first track in the queue. I reached for my phone, started the Roon app and noticed that the volume on the “Slaapkamer” Sonos Zone was muted (the light on the Sonos unit also burned permanently), while the two other Sonos Zones were still at volume level 46, just I had set them the night before. I pushed the Play button to start up the music again and changed the volume setting of the “Slaapkamer” Sonos back up to 46 again. I did this using the “+” button as can be seen in the logging)
Here’s the relevant part of this morning’s log:

Might this be a case of a “fading problem”, as you yourself named it somewhere else in this topic?

Hi @Hans_Valeton,

Unfortunately the log file is empty. To have a look at the issue I need the output of the Alarm Clock extension. If you use the Extension Manager you can do a “Restart (with logging)” for the Alarm Clock extension, as described in this post:

Hi @Jan_Koudijs,

Thanks for the tip.
This morning however, I have uninstalled the Extension Manager (as well as the Roon core and clients on my Windows machines) and have started anew to see if my (other) performance issues will disappear or persevere.

This time around I will wait till the core is absolutely stable before I install the Extension Manager again.
As soon as I have done so I will test the Alarm Clock again and let you know!

@Jan_Koudijs is it allowable or problematic to have more than one Alarm Clock instance running on the network. If one has 2 RPi’s running Ropieee with the AC turned on or perhaps a windows setup and a RPI will things break or will there just be 2 nodes that can be used for alarms?

Sorry about that. I just had a look and indeed the log file in my own directory is also empty. Must have made a copy-paste error of some sort.:pensive:
Unfortunately I don’t have the original log file anymore. I’ll just have to test again.

Should be fine when they run on separate devices, the problematic part can be to know which is which.

Did Roon 1.7 mess with Alarm Clock 0.7.4? Alarm Clock has disappeared from Extensions, although an entry still is shown under Authorizations. But there’s no place to control (eg, create, modify) Alarm Clock.

Should I re-install Alarm Clock?

Not that I know.

How was it installed, and on which platform? If you use the Extension Manager, and that is still listed, first step is to check if it can be started again via the manager. If it only provides the install option then that’s the next thing to try.

The Manager appears. Here’s what it shows:

If I click on Alarm Clock (in the right part), nothing shows beyond “(select extension), Alarm Clock, Random Radio.”

So you are using Windows. Can you please open Search in the Taskbar and enter the following path?


Is there a sub-folder named roon-extension-alarm-clock?

If not, then you should re-install by selecting Install from the Action pull-down and press Save.

OK, while in the roon-extension-alarm-clock folder, enter the next command:

npm list

What is the output?

OK, that’s the error I hoped for. This error is due to a change in dependencies of the Roon API. Good news is that I already released a fix for it. Update by performing the following steps in the Extension Manager (make sure you don’t have a Command or File Explorer window open in the RoonExtensions directory or one of its sub-directories):

  1. Select the Extension Manager from the System category and perform the Update action (you should update to v0.11.2)
  2. Select the Alarm Clock from the Playback category and perform the Update action (you stay at v0.7.4 but dependencies should be added)
  3. Select the Alarm Clock from the Playback category and perform the Start action

Let me know if this succeeds.

I am stuck at Extension Manager 0.10.1. Here’s what that looks like after I went through one iteration of trying install (update was not offered; I hit Save on the previous iteration):

I rebooted (to apply Windows maintenance) and tried again. Now I have this: