Roon Extension: CD Ripper v0.5.0

Ripping 2 CDs with the same name is something the current implementation can’t cope with. I’m working on an update of the CD Ripper in which a single ripped CD can already be converted to multi-disk, so that will be a workaround for your use case. There will be other changes as well, all meant to make it a more usable and robust solution.

What the ripper needs is that it gets fed with as many different CDs as possible to get edge cases like this covered. If you discover more troublesome rips, please let me know.

I send you a PM with an e-mail address to which you can send the log file.

CD Ripper v0.5.0 is now available

This release has some improvements and bug fixes:

  • Added forced rip, to rip CDs for which no metadata is available
  • Improved progress reporting during rip
  • Improved administration of the staging area to avoid mismatches causing “already ripped” messages
  • Allow multi-disk conversion even if there is only one rip in staging area
  • Fixed bug that caused truncating of album titles

@Geert_van_den_Belt, thanks for your feedback! This release is a direct result of it.

How to install / update

If the Extension Manager has auto update enabled then the changes will be pulled in the next time the update is performed. It is also possible to update manually via the Settings dialog, select the CD Ripper from the Tools category and perform the update action.

Thanks @Jan_Koudijs for the update!
I did retry “Chimes of Freedom”, and now it does recognise the different discs, and I can create the multi one also after ripping the first. So great improvement!

As I told you already about some of the other issues I had…
I did retry the WT, Mother Earth, CD 2 with v0.5.0 ‘Auto Rip’, and now it gets me an empty version in the Staging Area, no tracks.


I can select push and then have an empty directory as a result.
Anyway I’ll find another way to get this song done, no problem.

Regarding the cd’s that got ejected almost immediately.
As you suggested there are 2 reasons: no metadata or cd-r.
Only last Saturday just before you released the update I did actually test a cd-r, but it failed according to the logs because of lack of meta-data.
All others I tried were originals, but apparently not very popular cd’s.
I’m trying again one just now. It failed on ‘Auto Rip’, but today it suggested to start a forced rip, and that is going on now.
Curious to see how that gets out, and if Roon or Jaikoz will find me the meta-data or that I have to type…

1 Like

The strategy I choose here is that an Auto Rip will only be performed if metadata was found (allowing Roon to identify the rip). If no metadata was found then you can perform a forced rip and manually push this into your library. So you only get albums without metadata in your library if you explicitly instructed it to do so.

Since I’ve installed version v0.5.0 I notice some behaviour which I think isn’t completely intended.
I’ve noticed 2 issues. But the last couple of weeks I didn’t have to much time to give it a good try and also logging wasn’t always on.
First issue is that for some cd’s it doesn’t recognise them and states that there is no disc in the drive. I cannot use forced rip either. These cd’s can be ripped with other software, but…
For some I understand, like ‘Antología del flamenco’ Vol. 1 and 2, it not being able to find a match and that I have to use forced rip. But with this one I had the strange issue that I could do a forced rip for volume 1, but with vol.2 it kept coming back that there was no disc in the drive.
It made me doubt so I tried with a more popular cd, I thought, ‘Little Earthquakes’ from Tori Amos, but that also started reading the toc and then told me there was no disc.

The second issue I notice is that using Auto Rip, ripping starts, when I look next morning the cd is ejected, but when I look in Roon it doesn’t seem to be completely done, actually still busy:


It shows multiple instances of each track in the staging area:

I’ve seen this with at least 3 cd’s. For Blauw from The Scene I’ve added above screenshots and I will e-mail you the log.
I first noticed it with The Love Symbol album form Prince, which I then pushed resulting in all flac files in the folder, but no log file.
Then with another cd I re-inserted the ejected cd and Auto Rip finished the job and pushed it like normal. Same happened this morning with Blauw after re-inserting. So @Jan_Koudijs, I hope you can have a look, still very much like it, even with re-inserting the disc. Thanks for the great work.

I had a look through the log file and the issues are caused by troublesome rips.

The actual ripping is done by a tool called Whipper and if it is not able to successfully rip a track within 5 attempts it stops and the disk gets ejected. This is the case for “Love Symbol” and an unknown album (probably “Antología del flamenco Vol. 2”). I will improve the error reporting and avoid duplicate entries in the staging area in a future release, but there isn’t much I can do about these failing rips :frowning:

Ok, thanks again for having a look. I guess not all cd’s in the house are in pristine condition. I’ve found another issue though. I’ll email you the log again. Just ignore it if it gets to much, sorry.
Trying to rip “Antonio Vivaldi; Janine Jansen - The Four Seasons” it goes ok to rip it. But then when pushing the album it is almost immediately done and I’ve only some empty folders. Maybe because the semicolon?
(I’m able to manually copy the complete album before pushing via ssh.)

A post was split to a new topic: Ripping double Albums or box sets

I maybe missing a trick here.
Installed Extension Manager, went to Tools category but no CD Ripper Listed under Extension, only Art Scraper listed.

I believe it is because the CD Ripper extension requires Docker to be installed as well.

1 Like

Hi @Drew_Sams,

@Geoff_Coupe is right, the CD Ripper requires Docker.

The recommended setup is a Raspberry Pi with DietPi (see step 1 till 3 of this guide). If you are running a Linux system then that can be used as well.

Hi @Jan_Koudijs ,

I’ve been trying to use CD Ripper with Roon installed on QNAP NAS. External CDROM drive connected via USB.

I’ve installed newest Extension Manager in docker:

docker run -d --network host --restart unless-stopped --name roon-extension-manager --group-add 0 -v rem_data:/home/node/.rem/ -v /var/run/docker.sock:/var/run/docker.sock -e “TZ=Europe/Warsaw” theappgineer/roon-extension-manager:v1.x-standalone

It works but there is no CD Ripper on the list of available extensions.

Then I installed CD Ripper directly from Dockerhub. It starts, asks for share name but cannot find cdrom:

← REQUEST 253 com.roonlabs.settings:1/save_settings {“settings”:{“values”:{“share”:"/backup/music",“user”:"",“password”:"",“action”:1}},“is_dry_run”:false}
→ COMPLETE 253 Success {“settings”:{“values”:{“share”:"/backup/music",“user”:"",“password”:"",“action”:1},“layout”:[{“type”:“group”,“title”:“Global Settings”,“collapsable”:true,“items”:[{“type”:“string”,“title”:“Share”,“setting”:“share”}]},{“type”:“dropdown”,“title”:“Action”,“values”:[{“title”:"(select action)"},{“title”:“Scan Drive”,“value”:1}],“setting”:“action”}],“has_error”:false}}
→ CONTINUE 1 Changed {“message”:“Drive scanning in progress…”,“is_error”:false}
→ CONTINUE 250 Changed {“settings”:{“values”:{“share”:"/backup/music"},“layout”:[{“type”:“group”,“title”:“Global Settings”,“collapsable”:true,“items”:[{“type”:“string”,“title”:“Share”,“setting”:“share”}]},{“type”:“dropdown”,“title”:“Action”,“values”:[{“title”:"(select action)"},{“title”:“Scan Drive”,“value”:1}],“setting”:“action”}],“has_error”:false}}
← REQUEST 254 com.roonlabs.settings:1/unsubscribe_settings {“subscription_key”:“45”}
→ COMPLETE 254 Unsubscribed
stderr: “CRITICAL:whipper.command.drive:no drives found. Create /dev/cdrom if you have a CD drive, or install pycdio for better detection”
→ CONTINUE 1 Changed {“message”:“No drive found!”,“is_error”:true}
whipper exited with code: 0

Is there any way to make CD Ripper running in my environment?

Regards,
Piotr

That’s strange it should be in the Tools category.

NASes, these days, are pretty restricted when it comes to connecting USB devices (like optical drives and soundcards). Based on previous reports I think that the CD Ripper on a QNAP is a no go :frowning:

1 Like

@Jan_Koudijs I’m coming back to this extension but falling at first hurdle. I am using dietpi and it doesn’t seem to want to mount my cd drive at all. Any ideas?

On DietPi the default device, set during extension installation (i.e. /dev/cdrom), should typically work. If there is no drive detected than the device path has to be verified. For this you can follow the instructions that are provided for the CD Entrypoint.

Thanks will give that a go.

Hi @Jan_Koudijs. Before I moan a bit I want to thank you for your extension manager and CD Ripper extension. They are wonderful and fill a hole that Roon was wrong to create.

I am trying to rip a recent release: Taylor Swift Red (Taylor’s Version) from November 2021. The first disk went as expected, it’s the second disk that is giving me trouble. It’s stuck on track three in a verification loop that doesn’t end. Is there a way to solve this issue? I have tried restarting the app on my Mac mini and restarting the service on my server (ubuntu 20.04).

Hi @gefonas,

What I normally do in these cases is cleaning the CD, maybe it has a fingerprint or something.

Ok, I will try that. By the way, it’s a new CD that I lifted from the case to rip - if that makes any difference. Are your methods for cleaning varied? What is suggested?

If the CD did not have any plays then dirt is an unlikely cause. My rips are nowadays all from second hand CDs so then cleaning can be critical. The issue might be something specific for the underlying software that is used by the CD Ripper. Do you have an alternative ripping program for problematic CDs? What I use as a fallback is EAC running in Wine (on ubuntu).

If you can share the extension log files then I can see if I can find a cause for this.