Roon Extension: Deep Harmony - rich feature set for Logitech Harmony


(André Fluri) #363

Do I have to connect the hub to the computer for enabling xmpp or is it just made in the software remotly?


(simon arnold) #364

Do you have each zone as a separate activity?


(simon arnold) #365

No it’s via the harmony app harmony setup/devices and.activities


(simon arnold) #366

Your hubs activities will stop working properly after a while if you deny it internet access. Just install latest firmware and enable xmpp in the hubs settings.


(André Fluri) #367

Hi,
thanks, it worked fine with enabling it!

Further question, how do I add the device RokuTV for control roon?
Should it be recognized as a IP device?


(Isiah Lau) #368

No, any workaround?


(simon arnold) #369

Yes. You need to assign it remote ID in the extension which is part of the setup. Then in harmony app scan for new devices and you should see it pop up add it and then add it to the activity you want to control Roon.


(simon arnold) #370

If you want it to turn off other zones equipment then I believe you need to have each zone as a separate activity in the harmony and then in the extension you map each one to the Zone in Roon.


(Isiah Lau) #371

Thanks Simon!


#372

Hi, I must start the docker container after rebooting/restarting my Ubuntu Server NUC via ssh manually. Is there a way to do this automatically?

Enno


(Larry Post) #373

I think @Adam_Goodfellow has left the building. I still very much appreciate the work you’ve put into so far, thank you.


(Jan Koudijs) #374

Have you already set a restart policy for the container?

I always use the unless-stopped one.


#375

I use “docker run --detach --restart unless-stopped --network host khazul/roon-extension-deep-harmony”.

The docker container is always active but nevertheless I have to start it at a reboot of my Ubuntu server with “docker start”. It is not available in Roon without starting after the reboot.


(Isiah Lau) #376

Is that true? Who is the developer now?


(Larry Post) #377

No one. He last posted in January that he’s been busy, probably busy with life.


(Jan Koudijs) #378

Is the Docker daemon started at power-up?


(Jan Koudijs) #379

If @Adam_Goodfellow has lost interest then there is currently no possibility for someone to take over as the code hasn’t been published.


#380

Could You please let me know how to check this? Thanks.


#381

Further investigations are done.

I found out that “sudo systemctl enable docker” starts the docker service after a reboot. Now I can use my Logitech Harmony as it should be after rebooting. But the Extensions settings in Roon shows “No harmony hubs discovered”.

The big step foward is done. Any hints for the small one?:wink:


(Larry Post) #382

Wait 15 mins. or so. Still not found, reboot your Harmony Hub and wait another 15 mins. The discovery process can take a while, sometimes.