Roon Extension: Deep Harmony - rich feature set for Logitech Harmony

(Larry Post) #384

My setup has been like that a couple of times. It does what I want so I just leave it be. There are some Roon reset options you can try and ‘clean’ the config but if it’s doing what you want, don’t mess with it.


If your hubs are on latest firmware have you enable xmpp in the hubs settings via harmony app? You need to enable that now for hub to be recognised.

1 Like
(Larry Post) #386

Here’s the info to enable xmpp from Harmony (from ~100 posts ago).


Thanks guys. I use the latest firmware with xmpp enabled on both hubs. Before the last command “systemctl enable docker” the harmony hubs are recognized by the extension.

(Larry Post) #388

If you’ve not rebooted, Docker may not be running.

Try ‘systemctl start docker’ or ‘systemctl restart docker’.


With ‘systemctl restart docker’ the hubs are shown instantly within Roon. But after rebooting Ubuntu the hubs disappear until I restart the docker. Strange behaviour.

(Larry Post) #390

systemctl list-unit-files | grep enabled should show if docker service is set to startup. If not, systemctl enable docker


The docker service is set to startup and enabled after reboot. There are no hubs discovered even though the docker service is running. I have to restart the docker to see the hubs within Roon.

Is there a possibility to run in Ubuntu ‘systemctl restart docker’ or any other command after reboot automatically?

(Larry Post) #392

Several ways, some are more proper than others but it doesn’t really matter for this function. Try one and see if it works.

1 Like

Thank You, Larry. I will give it a try.


Hello Adam,
I use Roon server on Windows ltsc 64bit and Ropieee.
Can I use this setup, I don’t understand?
I’ve never used github before, and I don’t know how to do it.


Yes you can use that setup but you need to use git to download the files required. Just go here and download the zip for Windows and folllow the instructions here.


Hi, was wondering if someone can help me figure out how to get my devices to power on using Deep Harmony in Roon. My Logitech remote control works in the sense that it is able to tell Roon to pause and skip tracks, and so I think it is setup correctly, but when I play something in Roon, it does not power up my system. Am I supposed to be able to configure it so that it will power up my system? Thanks!

(Christoph Zeeb) #397

hi hammer

just wondering if it might be because harmony thinks the acitivity is already running? so there would be no need to power on the device?


Thank you. I’ve tried to test that by first turning off the Activity using the Harmony remote. Does this mean it actually works in your setup (eg., starting to play in Roon will trigger the power on via Harmony)?


All works for me. Press play in Roon for BlueSound Node 2 in Dining Room, it powers on my active speakers and sets the input and plays. I can control the volume of the speakers from Roon. Have you created an activity to use your devices and the control of Roon as this needs to be done for Harmony to turn it on. Have you added the external controls functionality in the device settings ?

(Christoph Zeeb) #400

works for me too.

Maybe your settings have to be cahnged (as shown in screenshots of crystalgipsy) to “Use source control”.

Another issue i was confronted with when setting the extension up: It did add the hub (or the remote?) twice when i had to change firmware of hub. Thus doublecheck your settings for this too and redo all steps as described here:

hope this helps!

(Christoph Zeeb) #401

The source code seems to be published here, just below the donate link:


Thank you! That was the part I was missing!

Now that it turns on and I see I can also turn the system off my hitting the “Power Button” in Roon, is there a way to ask Roon to turn the system off after x minutes of inactivity?


No you cant do that. Although you might be able to do that with the Alarm Clock extension. Not sure it would power off everything though.